Hi,

This procedure changes the CRS but the extent remains the same. The question is 
how to reproject the extent of the shape.

Thanks,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: DelazJ [mailto:del...@gmail.com]
Verzonden: donderdag 1 september 2016 15:32
Aan: Reginald Carlier
CC: Nicolas Cadieux; qgis-user@lists.osgeo.org
Onderwerp: Re: [Qgis-user] clip still not working on osm shape

Hi,
Reginald, in QGIS, Layer menu --> Save As ... (or simply a right-click on the 
layer) helps you create a reproject the layer in another projection. This is an 
easy way you could (actually) change the crs of your layers. Once done, the 
clip process should have succeeded.
Changing the projection in the layer properties is not the way to do it.

2016-09-01 14:35 GMT+02:00 Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>>:
Hi,

I found that the problem was the conversion of the CRS. When I select the shape 
of the town (Lambert 72) in QGIS Browser and choose WGS 84 as CRS the extent is 
still in Lambert coordinates. I tried the same in ArcMap and there I got the 
same result. Then I tried a function in the toolbox under Data Management > 
Projections and Transformations > Project where you can choose the CRS and also 
the transformation algorithm. Then the shape of the town was shown in the right 
spot. I wonder if there is such a tool in QGIS.

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39<tel:%2B32%2051%2033%2074%2039> 
www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: Nicolas Cadieux 
[mailto:nicolas.cadi...@archeotec.ca<mailto:nicolas.cadi...@archeotec.ca>]
Verzonden: donderdag 1 september 2016 13:36
Aan: Reginald Carlier
Onderwerp: Re: clip still not working on osm shape

Hi,
Are you running the latest Qgis 2.16? If so, vector tool should be in the 
processing toolbox and not in the vector menu.  I have only worked one day with 
2.16 but it was long enough to see that it needed a complete removal of all 
previous versions as the menu had a mixe of the old and the new version.  After 
that, vector tools disappeared from the vector menu and reappeared in the new 
processing menu.  I had read about this in a French blog so I was expecting it. 
 Could this be the cause of your problem?

If not, make sure both layers are in the same CRS (like you did) but that they 
also align properly when the "CRS on the fly" is not activated.  Try loading 
only those two layers.  You could test to see if it's the osm file format that 
is giving you problems by testing the two .shp file.

Nicolas

Envoyé de mon iPad

Le 1 sept. 2016 à 05:33, Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>> a 
écrit :
Hi Nicolas,

I changed the CRS of the shapefiles so they match (EPSG 4326).
It takes about 30 seconds before the algorithm (Vector > Geoprocessing > 
Clippen) finisches.
Then it loads the resulting shapefile in QGIS but the attributetable is empty 
and the resulting shp is 1 kB.
It looks as the Clip function doesn’t work.

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39<tel:%2B32%2051%2033%2074%2039> 
www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org<mailto:Qgis-user@lists.osgeo.org>
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to