Hi,

I tried the Reprojection layer tool but that doesn’t change the extent. The 
reprojected layer appears in the same spot as the old layer.

Reginald,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: Nicolas Cadieux [mailto:nicolas.cadi...@archeotec.ca]
Verzonden: donderdag 1 september 2016 16:31
Aan: Reginald Carlier
CC: qgis-user@lists.osgeo.org
Onderwerp: Re: clip still not working on osm shape

Hi,
You are correct.  Sorry, I was working from memory.  Try Qgis geoalgorithms, 
Reprojection layer. You can search the processing plugin with"reprojection".

The right click is to activate toolbars for the "digitizing"and "advanced 
digitizing toolbars."

Nicolas

Envoyé de mon iPad

Le 1 sept. 2016 à 09:57, Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>> a 
écrit :
Hi Nicolas,

I’m a little lost here. I use QGIS 2.16.1. When I right click next to the 
toolbars I see no plugin that changes the CRS.
When I save a file there is no option to choose the input CRS and output CRS. 
You can choose the CRS and there’s a checkbox to choose the extent which is not 
checked by default. So I don’t know what to do if I want to change the extent 
to the new CRS.
Which of the 111 geo algorithms should I use to change the CRS and reproject 
the extent?

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: Nicolas Cadieux [mailto:nicolas.cadi...@archeotec.ca]
Verzonden: donderdag 1 september 2016 15:24
Aan: Reginald Carlier
CC: qgis-user@lists.osgeo.org<mailto:qgis-user@lists.osgeo.org>
Onderwerp: Re: clip still not working on osm shape

Hi,
To modify the shape files, you need to activate the toolbars by right clicking 
next to a toolbar.  You will find a number of plugins also to help modify 
object.

When you save a file, I think you have a input CRS and a output CRS.  Make sure 
the add both.  If it's not there, look in the processing toolbar for Qgis 
reprojection tools.  What version of Qgis are you working with?

Nicolas

Envoyé de mon iPad

Le 1 sept. 2016 à 09:11, Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>> a 
écrit :
Hi,

No as I used QGIS Browser there is no option to save the changes. Also it would 
be great if there was an option to copy, paste or delete a shape.
I guess I have to load the shape in QGIS and change the CRS and then use ‘save 
as’, but when I do that the saved shp shows in the same place as the unchanged 
shp.
How can I adjust the extent so that it shows in the right location?

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: Nicolas Cadieux [mailto:nicolas.cadi...@archeotec.ca]
Verzonden: donderdag 1 september 2016 14:50
Aan: Reginald Carlier
Onderwerp: Re: clip still not working on osm shape

Hi,
Did you resave the file in a new projection or just specified the layer 
projection by clicking on the layer in the layer manager?

You need to save the file for the changes to be permanent.  There are also more 
complex reprojection tools in Qgis.

Nicolas

Envoyé de mon iPad

Le 1 sept. 2016 à 08:35, Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>> a 
écrit :
Hi,

I found that the problem was the conversion of the CRS. When I select the shape 
of the town (Lambert 72) in QGIS Browser and choose WGS 84 as CRS the extent is 
still in Lambert coordinates. I tried the same in ArcMap and there I got the 
same result. Then I tried a function in the toolbox under Data Management > 
Projections and Transformations > Project where you can choose the CRS and also 
the transformation algorithm. Then the shape of the town was shown in the right 
spot. I wonder if there is such a tool in QGIS.

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
Van: Nicolas Cadieux [mailto:nicolas.cadi...@archeotec.ca]
Verzonden: donderdag 1 september 2016 13:36
Aan: Reginald Carlier
Onderwerp: Re: clip still not working on osm shape

Hi,
Are you running the latest Qgis 2.16? If so, vector tool should be in the 
processing toolbox and not in the vector menu.  I have only worked one day with 
2.16 but it was long enough to see that it needed a complete removal of all 
previous versions as the menu had a mixe of the old and the new version.  After 
that, vector tools disappeared from the vector menu and reappeared in the new 
processing menu.  I had read about this in a French blog so I was expecting it. 
 Could this be the cause of your problem?

If not, make sure both layers are in the same CRS (like you did) but that they 
also align properly when the "CRS on the fly" is not activated.  Try loading 
only those two layers.  You could test to see if it's the osm file format that 
is giving you problems by testing the two .shp file.

Nicolas

Envoyé de mon iPad

Le 1 sept. 2016 à 05:33, Reginald Carlier 
<reginald.carl...@ingelmunster.be<mailto:reginald.carl...@ingelmunster.be>> a 
écrit :
Hi Nicolas,

I changed the CRS of the shapefiles so they match (EPSG 4326).
It takes about 30 seconds before the algorithm (Vector > Geoprocessing > 
Clippen) finisches.
Then it loads the resulting shapefile in QGIS but the attributetable is empty 
and the resulting shp is 1 kB.
It looks as the Clip function doesn’t work.

Regards,


Reginald Carlier
Deskundige GIS

[http://www.ingelmunster.be/ingelmunster.gif]

Gemeente Ingelmunster, Oostrozebekestraat 4, 8770 Ingelmunster
T +32 51 33 74 39 www.ingelmunster.be<http://www.ingelmunster.be>

[http://www.ingelmunster.be/fb.jpg]<https://www.facebook.com/Ingelmunster/> 
[http://www.ingelmunster.be/go.jpg] <https://plus.google.com/+ingelmunster>  
[http://www.ingelmunster.be/in.jpg] <https://www.instagram.com/ingelmunster/>  
[http://www.ingelmunster.be/pi.jpg] <https://www.pinterest.com/ingelmunster/>  
[http://www.ingelmunster.be/tw.jpg] <https://twitter.com/ingelmunster>
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to