I am in the middle of multiple tests with CF/IDE and SD/IDE readers with different type/size of CF and SD

Few words about the 2 machine I am using :

- Q40 with 1 IDE controller card with primary channel (master/slave) and secondary (master/slave) on the same Card so in total 4 IDE devices: as primary master I have a classic 80 GB IDE HD (2 atari partition), as slave I have a CDROM. On the secondary channel as a master I have an IDE/CF adapter. (StarTech 3.5 Drive Bay IDE to single CF SSD adapter card reader). The second ISA slot is occupied by ethernet card. SMSQ/E 2.92 on rom, then I load newer SMSQ/E (3.36) from primary master disk. All the different combination of CF/SD I use on the StarTech are fine. The system is working well and stable . Q40 is very tolerant with any CF/SD reader I tried to used: I also replaced main primary (master) classic 80 GB with a single SD reader (Kalea Informatique - Adapteur Convertisseur IDE 3.5 40 pin vers SD Card) and also everything works fine.....

- Q60: SMSQ/E 2.98 on Rom, 2 IDE cards ESIO v2.1, no ethernet. I had also in the past a 2 slot ISA riser card to use the 2 IDE controller at the same time with ethernet card (used with linux Shoestring), but at the moment I removed the riser card (and linux) and I use the 2 IDE cards in the single ISA slotᅵ with no Ethernet. Theᅵ 2 IDE card ESIO v2.1 are configured so that one is the primary ide card (IDE address primary IRQ 14) with ser1 and ser2, the second card is configured as secondary (IDE address secondary IRQ 15) with ser3 and ser4. Attached to the first primary card I have: Syba SD-ADA45006 Lecteur de Carte memoire interne IDE, it is a CF reader able to have the master CF on one side and the slave CF on the other side. As master I have an IBM Microdrive withᅵ 2 atari partition used only to boot newer SMSQ/E and as slave I have a toshiba 4GB SD inserted into a passive CF2SD adapter type II (K komputer K Bay). The SD have 2 partitions. All work fine, I repeat that all work fine with SMSQ/e 3.36 (last revision)

- Same Q60 as before but with SMSQ/e 3.36 on rom......here the situation is more complex. After having upgraded my Q60 with newer roms, the tolerance with CF readers and different type of SD/CF cards are totally different. The same Syba adapter is in place and works fine booting directly QXL.WIN (and it is very fast), but i realized that most of the other CF readers I tried DON'T work any more as before. This issue seems to address newer SMSQ/E in Eprom, I used second hand ST M27C1024 eprom 120ns. I ordered completely new eprom from China the same Brand but with 100ns.....not sure where is the problem.

This is the situation as of yesterday night, it is really hard and time consuming test all different combination of devices .


On 11/05/2020 22:35, Thierry Godefroy via Ql-Users wrote:
On Thu, 23 Apr 2020 23:42:31 +0200, Peter Graf via Ql-Users wrote:

Fabrizio Diversi via Ql-Users wrote:
-ᅵᅵᅵ As a slave I have a 4 GB Toshiba SD HC with a CF adapter Type II.
Ah! Very good idea! With the right passive CF-IDE adapters, those might
not suffer the same problem as the SD-IDE converters, which allow no
I'm afraid things are not *that* simple... :-(

Based on Fabrizio's report, I bought and tried this adapter:

Sadly, when plugged into the IDE to CF Card adapter (duly configured as
a slave and which does cause a genuine CF Card to indeed behave as an
IDE slave device when plugged in this adapter), the SDHC+CF card adapter
combo behaves like if it is alone on the IDE bus, masking any other
device connected to it (in my case, an IDE HD configured as master).

I also tried to configure the IDE-CF adapter as master and the DD as
slave, but the DD is still not seen on the bus when the SDHC+CF card
adapter combo is plugged into the IDE-CF Card adapter.

I returned that device today since it's of no use at all to me...

If Fabrizio could quote the brand and model of his working SDHC to CF
card adapter, it would save us a lot of troubles finding one that works
as intended...

QL-Users Mailing List
QL-Users Mailing List

Reply via email to