On October 12, 2017 4:25:29 PM MDT, Person <xueyilu...@gmail.com> wrote:
>l tried the former commands again, with “ls -lh” and “pwd”, but the
>terminal remained unresponsive, even if it was formerly responsive.
>So I tried changing the command around a little. The Qubes site
>mentions to enter this command: “qvm-run --pass-io <src-vm> 'cat
>/path/to/file_in_src_domain' > /path/to/file_name_in_dom0”, and I
>realized that I didn’t put in a desired path for the file in dom0. I
>tried using a directory in dom0 that I found, which was
>/home/user/Downloads. When I entered this command, dom0’s response was
>“Usage: qvm-run [options] [<vm-name>] [<cmd>]” and “qvm-run: error: Too
>many arguments”. I’m not too sure what this means, but I believe I
>somehow typed in the command wrong. I typed in “qvm-run —pass-io
>sys-net ‘cat /home/user/Downloads’ /home/user/Downloads”. (The first
>“/home/user/Downloads is the directory in sys-net and the second is the
>directory in dom0.)

Where you show the command you typed, you're missing the output redirection 
(the ">"). So instead of the shell doing the redirection to the file, it passes 
it as an argument to the qvm-run command, resulting in the error you got.


You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to