Looks like you're missing the will_paginate gem. Try gem install
will_paginate, or grab it from http://github.com/mislav/will_paginate

Alex

On Mon, Nov 16, 2009 at 9:58 PM, Rob Levin <roblevinten...@gmail.com> wrote:

> Wondering what to do to get comments extension to work. When I run the
> ./script/server -e [production|development] and go to the extensions
> tab in Admin I see the comments extension and also, a “Comments” tab
> showed up on the right of Admin. But I still got the following error
> when I click on it:
>
> NoMethodError in Admin/commentsController#index
> undefined method `paginate' for #<Class:0x238bb8c>
>
> Note that before the above I'd done:
>    git clone git://github.com/sjlombardo/radiant-comments.git
> from the /vendor/extensions dir and renamed: `mv radiant-comments/
> comments/`
>
> Then I had to hack the source of
> /vendor/extensions/comments_extension.rb for the include application
> to:
>
>    begin
>       require_dependency 'application_controller'
>    rescue MissingSourceFile
>       require_dependency 'application'
>    end
>
> And here are my local gems:
> gem list --local
> actionmailer (2.3.4, 1.3.6)
> actionpack (2.3.4, 1.13.6)
> actionwebservice (1.2.6)
> activerecord (2.3.4, 2.2.2, 1.15.6)
> activeresource (2.3.4)
> activesupport (2.3.4, 2.2.2, 1.4.4)
> acts_as_ferret (0.4.1)
> builder (2.1.2)
> capistrano (2.0.0)
> cgi_multipart_eof_fix (2.5.0)
> cheat (1.2.1)
> columnize (0.3.1)
> configuration (1.1.0)
> cucumber (0.4.0.rc1, 0.3.104)
> daemons (1.0.9)
> diff-lcs (1.1.2)
> dnssd (0.6.0)
> extlib (0.9.13)
> fastercsv (1.5.0)
> fastthread (1.0.1)
> fcgi (0.8.7)
> ferret (0.11.4)
> flexmock (0.8.6)
> flickraw (0.7.1)
> gem_plugin (0.2.3)
> gemcutter (0.1.6)
> git (1.2.5)
> heckle (1.4.3)
> heroku (1.3.0, 1.2.1)
> highline (1.5.1, 1.2.9)
> hpricot (0.6)
> jeweler (1.3.0)
> johnson (1.1.2)
> json (1.1.9)
> json_pure (1.1.9)
> launchy (0.3.3)
> libxml-ruby (0.9.5, 0.3.8.4)
> linecache (0.43)
> mechanize (0.9.3)
> mislav-will_paginate (2.3.11)
> mongrel (1.1.4)
> mysql (2.8.1)
> needle (1.3.0)
> net-scp (1.0.2)
> net-sftp (1.1.0)
> net-ssh (2.0.15, 1.1.2)
> nokogiri (1.4.0, 1.3.3)
> ParseTree (3.0.4)
> polyglot (0.2.9)
> rack (1.0.0)
> radiant (0.8.1)
> rails (2.3.4, 1.2.6)
> rake (0.8.7, 0.7.3)
> rdiscount (1.3.5, 1.3.4)
> RedCloth (4.2.2, 3.0.4)
> rest-client (1.0.3)
> rhodes (1.2.1)
> rhodes-build (1.2.1)
> rhodes-framework (1.2.1)
> rhodes-generator (1.2.1)
> rspec (1.2.9, 1.2.9.rc1)
> rspec-rails (1.2.9, 1.2.9.rc1)
> ruby-debug (0.10.3)
> ruby-debug-base (0.10.3)
> ruby-openid (1.1.4)
> ruby-yadis (0.3.4)
> ruby2ruby (1.2.4)
> ruby_parser (2.0.4)
> rubyforge (2.0.0)
> rubygems-update (1.3.5, 1.3.1)
> RubyInline (3.8.3)
> rubynode (0.1.3)
> rvm (0.0.62, 0.0.49)
> sanitize (1.1.0)
> Selenium (1.1.14)
> selenium-client (1.2.17)
> sequel (3.0.0)
> session (2.4.0)
> sexp_processor (3.0.3)
> sinatra (0.9.2)
> sqlite3-ruby (1.2.1)
> taps (0.2.19)
> templater (1.0.0)
> term-ansicolor (1.0.4)
> termios (0.9.4)
> thor (0.9.9)
> treetop (1.4.2)
> visionmedia-bind (0.2.6)
> visionmedia-commander (3.2.9)
> visionmedia-jspec (2.11.2)
> webrat (0.6.rc1)
> xml-simple (1.0.12)
> yahoo-weather (1.0.0)
> ZenTest (4.1.4)
> _______________________________________________
> Radiant mailing list
> Post:   Radiant@radiantcms.org
> Search: http://radiantcms.org/mailing-list/search/
> Site:   http://lists.radiantcms.org/mailman/listinfo/radiant
>
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to