Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 1967 by post-review 0.3 unexpected diff behaviour and git repository fatal error

*NOTE: Do not post confidential information in this bug report.*

What version are you running?
Review Board 1.5.2 on the server
RBTools 0.3 on the Windows Client

What's the URL of the page containing the problem?
http://<private-domain>/api/review-requests/x/diffs (where x is a number)

What steps will reproduce the problem?
-Python, Setuptools were installed.
-Used easy_install to install RBTools.
-I'm using msysgit Git with unix tools installed.
-I set the reviewboard.url configuration key in Git.
-I also created a .reviewboardrc file under 'Home' in C:\Users\username\AppData\Roaming with the same value for the REVIEWBOARD_URL parameter. -I read in the release notes that RBTools 0.3 uses the Git diff, so I did not install GNU's DiffUtils.

1. I'm using Git, and I had not yet pulled down the latest code from master, but had made my own changes since the last pull. 2. I invoked post-review and was greeted with the "There don't seem to be any diffs!" message. 3. I re-ran post-review several more times, including with the debug option, but I didn't see anything that stood out. 4. I executed git diff which correctly output the changes I had made since my last pull. 5. I decided to pull from master and re-ran post-review. Surprisingly, post-review got further along, but not all the way. The debug option revealed that it created a review request but when uploading diff of size 9680, an error occured;
GOT API Error 105 (HTTP code 400): One or more fields had errors
Error data: {u'fields': {u'path': [u"fatal: Not a git repository" 'None'\n"]}, u'stat': u'fail', u'err' : u'One or more fields had errors', u'code': 105}}

Error uploading diff

The generated diff file was empty. This usually means no files were modified in this change.

Try running with -output-diff and --debug for more information.

Your review request still exists, but the diff is not attached.

6. When I invoke the diff command (git diff --no-color --full-index --no-ext-diff 3b1d3ee1c56b62fc01be53d6f74e11fb1b2fd0e4..refs/heads/master) as reported by post-review with the debug option, I get a different output than I expect. I get the diff between the latest two pushed commits. None of my local changes are shown in the diff.

7. As a last effort, I ran git diff > my_diff_file and used that file as a parameter to --diff-filename=my_diff_file. I can tell a different diff than in 5 was posted to the server because the size was reported to be 845. However, I received the same error.

What is the expected output? What do you see instead?

So, there are a few things to point out here.
-Not a git repository in the error is alarming. Is it referring to incorrect configuration of the Git repository on the server side? I am unfamiliar with the flow of events. If post-review is generating a diff on the client-side, what is the Review Board server attempting to do with Git repository. -How come the git diff command run by post-review is not diff'ing MY local changes...

What operating system are you using? What browser?

Windows 7

Please provide any additional information below.

You received this message because you are subscribed to the Google Groups 
"reviewboard-issues" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to