I'm advocating the adoption of review-board in my company. The client
and the server must run in Windows. Subversion is our version control
system. I'm not using cygwin nor mingw.

My greatest obstacle is to make it easy to upload a "changeset" for
review.

To make review-board run I installed patch,exe in the server. In the
client, I had to install diffutils for post-review. Downloaded both
from here:
http://gnuwin32.sourceforge.net/packages.html

post-review worked after I've set the http_proxy environment variable
to nothing. It tried to access the review-board server in my local
network through my company proxy and it required authentication.

I've successfully  upload some patches for reviewing using TortoiseSVN
"create patch" menu option. Unfortunately the subversion client
doesn't include in the patch files that were added to my local copy.

Then I tried to use post-review this way:

C:\xxx>python  E:\reviewboard\contrib\tools\post-review --revision-
range=15843:15844  --server=http://subversion-test:8000  -d

The answer  was:

   Review request #13 posted.

   http://subversion-test:8000/r/13

But when I try to click on 'view diff' (http://subversion-
test.sol.local:8000/r/13/diff/#index_header ), the following error
appears:

Traceback (most recent call last):
  File "D:\reviewboard\diffviewer\views.py", line 86, in view_diff
    files = get_diff_files(diffset, None, interdiffset, highlighting)
  File "D:\reviewboard\diffviewer\diffutils.py", line 651, in
get_diff_files
    enable_syntax_highlighting)
  File "D:\reviewboard\diffviewer\diffutils.py", line 567, in
generate_files
    lambda: get_chunks(filediff.diffset,
  File "D:\reviewboard\djblets\util\misc.py", line 55, in
cache_memoize
    data = lookup_callable()
  File "D:\reviewboard\diffviewer\diffutils.py", line 570, in <lambda>
    enable_syntax_highlighting))
  File "D:\reviewboard\diffviewer\diffutils.py", line 338, in
get_chunks
    new = get_patched_file(old, filediff)
  File "D:\reviewboard\diffviewer\diffutils.py", line 254, in
get_patched_file
    return patch(filediff.diff, buffer, filediff.dest_file)
  File "D:\reviewboard\diffviewer\diffutils.py", line 125, in patch
    (filename, tempdir, patch_output))
Exception: The patch to '/sac/trunk/xxx/xxx/xxxxx.html' didn't apply
cleanly. The temporary files have been left in 'c:
\docume~1\admini~1\locals~1\temp\reviewboard.5bnxay' for debugging
purposes.
`patch` returned: patching file c:\docume~1\admini~1\locals~1\temp
\reviewboard.5bnxay\tmpxptjxx
patch: **** malformed patch at line 51: \ No newline at end of file


The advice for similar error messages in the web tell me to upgrade
patch, but I'm already using version 2.5.9.

There's no error messages in the manage.py server output.

If I go to the temp dir above and try to manually apply the patch, the
same error message bites me:

C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\reviewboard.2vsmde>patch tmpvvbvlu
ProcMensagem.html.diff
patching file tmpvvbvlu
patch: **** malformed patch at line 51: \ No newline at end of file

Any idea how to fix it?
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to