I don't know about the diffviewer error but can answer other

1. Review board only knows about the code that you submit to it. If
you want to see version histories of the file, you need to go to
Bazaar. However,
if you update the diff as the result of a review comment, they will be
shown as revisions in review board. This way a reviewer can easily
find what
changed between the original review request and the update he just got
after the developer incorporated the review comments.
2. Correct. Review will not submit the code in SCM.


On Apr 9, 12:33 am, Ritesh Nadhani <rite...@gmail.com> wrote:
> Hi
> On Tue, Apr 7, 2009 at 7:17 PM, Christian Hammond <chip...@chipx86.com> wrote:
> > There's a bug that will be fixed in the next beta where registration is
> > turned off by default yet appears on in the settings. You'll need to log in
> > as the admin user you created during install, go into the admin UI ->
> > General Settings, make sure registration is enabled, and hit Save. It should
> > then work.
> Thanks. I went thru the steps you suggested and it worked. I initially
> had trouble submitting request but I found out that I need to create
> some default reviewers.
> But when I submit a patch and go to View Diff, I get:
> http://paste.pocoo.org/show/111638/
> what can I be doing wrong?
> Also, I have two questions:
> 1) One more question before I take a leave. I assume that review board
> does no show complete diffs from the history and only keep tracks of
> patches etc submitted thru it.
> 2) When I review a patch and choose ship it, the code is actually not
> pushed to the repository. Correct?
> Thanks, this is looking really great.
> > Christian
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.review-board.org
> > VMware, Inc. -http://www.vmware.com
> > On Tue, Apr 7, 2009 at 6:55 PM, riteshn <rite...@gmail.com> wrote:
> >> Hi
> >> This is our first time using the product as we review it if suits our
> >> needs. We plan to use it with Bazaar.
> >> I got the reviewboard and all the dependencies installed. Copying the
> >> modpython conf file to apache sites-available directory and when I go
> >> to the browser it shows up too.
> >> It is always in the login page and when i click on Register it always
> >> reverts back to login page. Thus I am not able to setup the site as
> >> suggested at:
> >>http://www.mail-archive.com/reviewboard@googlegroups.com/msg01548.html
> >> During setup, I chose default authentication.
> >> Can somebody tell me what simple mistake I am doing?
> >> -- Ritesh
> --
> Riteshhttp://www.riteshn.com
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to