It says to install Patch.exe. However, I have installed it, it's in the
path. And I read another post that suggested copying Patch.exe to the
apache/bin folder (which I thought a bit odd).

I installed PIL from an installer. I can import PIL from a python shell.

Python 2.5.1, PIL 1.1.6, Apache 2.2,
Using SQLite and mod_python, without memcache.

The only error in the apache log is about a python version mismatch
expecting 2.5 and finding 2.5.1.

I now believe it's some sort of path issue. Typically I can access
http://localhost/xampp for xampp settings... but currently even that URL
shows the Manual Server Updates page.

I've tried various changes in the configuration but haven't gotten
anywhere... this is the current state of that:

<VirtualHost *:80>
    ServerName localhost/reviewboard
    DocumentRoot "C:/xampp/xampplite/htdocs/reviewboard/htdocs"

    # Error handlers
    ErrorDocument 500 /errordocs/500.html

    # Serve django pages
    <Location "/">
        PythonPath "['C:/xampp/xampplite/htdocs/reviewboard/conf'] +
sys.path"
        SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
        SetEnv PYTHON_EGG_CACHE
"C:/xampp/xampplite/htdocs/reviewboard/tmp/egg_cache"
        SetHandler mod_python
        PythonHandler django.core.handlers.modpython
        PythonAutoReload Off
        PythonDebug Off
        # Used to run multiple mod_python sites in the same apache
        PythonInterpreter reviewboard_reviewboard
    </Location>

    # Serve static media without running it through mod_python
    # (overrides the above)
    <Location "/media">
        SetHandler None
    </Location>
    <Location "/errordocs">
        SetHandler None
    </Location>

    <Directory "C:/xampp/xampplite/htdocs/reviewboard/htdocs">
        AllowOverride All
    </Directory>

    # Alias static media requests to filesystem
    Alias /media "C:/xampp/xampplite/htdocs/reviewboard/htdocs/media"
    Alias /errordocs
"C:/xampp/xampplite/htdocs/reviewboard/htdocs/errordocs"
</VirtualHost>


Thanks a ton for the guidance. Is there any other information I left out?



On Tue, Jan 5, 2010 at 3:11 PM, Christian Hammond <chip...@chipx86.com>wrote:

> There are several Manual Server Updates pages. What instructions is this
> one referring to?
>
> How did you install PIL? And what version of Python is PIL and Review Board
> using?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
>
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
> On Tue, Jan 5, 2010 at 11:17 AM, Anthony <awhita...@gmail.com> wrote:
>
>> I have this same problem... except PIL is installed correctly. The
>> main page shows a yellow box that says "Manual server updates
>> required" and a blue box that says something about installing Gnu
>> Patch. Patch is installed and is in the path. I can run it from any
>> command line.
>>
>> Any ideas?
>>
>> On Dec 16 2009, 8:00 am, Dregel <dre...@gmail.com> wrote:
>> > This did the trick:
>> > yum install python-imaging
>> >
>> > On Dec 15, 4:44 pm, Dregel <dre...@gmail.com> wrote:
>> >
>> > > Looks like the installation of PIL did fail. I'll start there then.
>> > > Cheers!
>> >
>> > > Python 2.4.3 (#1, Sep  3 2009, 15:37:37)
>> > > ...>>> import PIL
>> >
>> > > Traceback (most recent call last):
>> > >   File "<stdin>", line 1, in ?
>> >
>> > > Easy_install, yeah right...
>> >
>> > > On Dec 15, 1:17 am, Christian Hammond <chip...@chipx86.com> wrote:
>> >
>> > > > From a python prompt, type:
>> >
>> > > >     import PIL
>> >
>> > > > If that fails, then PIL is not installed on the system. If it does
>> work,
>> > > > then we need to investigate why your Python isn't seeing it. I
>> assume you've
>> > > > done a webserverrestart since installing Review Board?
>> >
>> > > > Christian
>> >
>> > > > --
>> > > > Christian Hammond - chip...@chipx86.com
>> > > > Review Board -http://www.reviewboard.org
>> > > > VMware, Inc. -http://www.vmware.com
>> >
>> > > > On Mon, Dec 14, 2009 at 4:03 PM, nshenry03 <nshenr...@gmail.com>
>> wrote:
>> > > > > I am getting the same issue:
>> >
>> > > > > r...@scubuntuvm1:~# python --version
>> > > > > Python 2.5.2
>> > > > > r...@scubuntuvm1:~# lsb_release -a
>> > > > > No LSB modules are available.
>> > > > > Distributor ID: Ubuntu
>> > > > > Description:    Ubuntu 8.04.3 LTS
>> > > > > Release:        8.04
>> > > > > Codename:       hardy
>> > > > > r...@scubuntuvm1:~# uname -r
>> > > > > 2.6.24-23-generic
>> >
>> > > > > On Dec 14, 2:26 pm, Christian Hammond <chip...@chipx86.com>
>> wrote:
>> > > > > > Hi,
>> >
>> > > > > > The manualupdatespage is old and generally isn't seen anymore.
>> We'll
>> > > > > need
>> > > > > > to update the text to reference rb-site instead of manage.py.
>> >
>> > > > > > The error definitely seems to be that PIL isn't installed
>> correctly. Yes,
>> > > > > > easy_install should get it, but perhaps something went wrong.
>> What
>> > > > > version
>> > > > > > of Python is being used on the system?
>> >
>> > > > > > Christian
>> >
>> > > > > > --
>> > > > > > Christian Hammond - chip...@chipx86.com
>> > > > > > Review Board -http://www.reviewboard.org
>> > > > > > VMware, Inc. -http://www.vmware.com
>> >
>> > > > > > On Mon, Dec 14, 2009 at 12:07 PM, Dregel <dre...@gmail.com>
>> wrote:
>> > > > > > > Hi,
>> >
>> > > > > > > After following the installation guide, I got RB kind of
>> working on
>> > > > > > > centos but when I go to default page I get the message:
>> Manualserver
>> > > > > > >updatesrequired
>> >
>> > > > > > > The suggestion is to run manage.py. After some investigation I
>> found
>> > > > > > > someone that recommended a rb-site upgrade instead and that
>> command
>> > > > > > > reveals a problem:
>> >
>> > > > > > > []# rb-site -d upgrade /var/www/reviewboard
>> > > > > > > Rebuilding directory structure
>> > > > > > > Updating database. This may take a while.
>> > > > > > > Error: One or more models did not validate:
>> > > > > > > reviews.screenshot: "image": To use ImageFields, you need to
>> install
>> > > > > > > the Python Imaging Library. Get it at
>> > > > > > >http://www.pythonware.com/products/pil/
>> > > > > > > .
>> >
>> > > > > > > What gives? I thought PIL was correctly installed when running
>> > > > > > > easy_install but it's not working. Any suggestions?
>> >
>> > > > > > > --
>> > > > > > > Want to help the Review Board project? Donate today at
>> > > > > > >http://www.reviewboard.org/donate/
>> > > > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
>> > > > > > > -~----------~----~----~----~------~----~------~--~---
>> > > > > > > To unsubscribe from this group, send email to
>> > > > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
>> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
>> >
>> > > > > <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
>> <reviewboard%252bunsubscr...@googlegroups.com<reviewboard%25252bunsubscr...@googlegroups.com>
>> >
>> >
>> > > > > > > For more options, visit this group at
>> > > > > > >http://groups.google.com/group/reviewboard?hl=en
>> >
>> > > > > --
>> > > > > Want to help the Review Board project? Donate today at
>> > > > >http://www.reviewboard.org/donate/
>> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
>> > > > > -~----------~----~----~----~------~----~------~--~---
>> > > > > To unsubscribe from this group, send email to
>> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
>> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
>> >
>> > > > > For more options, visit this group at
>> > > > >http://groups.google.com/group/reviewboard?hl=en
>>
>> --
>> Want to help the Review Board project? Donate today at
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>>
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to
>> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
>> For more options, visit this group at
>> http://groups.google.com/group/reviewboard?hl=en
>>
>
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>
-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to