Sorry to be a pain, but I am getting the following error in the logs
when trying to create a new review request.
The reposotory drop down just appears empty in the UI.

2010-02-25 17:29:51,671 - ERROR - Error loading SCMTool for repository
Replay (ID 1): DLL load failed: The specified procedure could not be
found.
Traceback (most recent call last):
  File "c:\python25\lib\site-packages\ReviewBoard-1.0.5.1-py2.5.egg
\reviewboard\reviews\forms.py", line 62, in __init__
    self.field_mapping[repo.id] = repo.get_scmtool().get_fields()
  File "c:\python25\lib\site-packages\ReviewBoard-1.0.5.1-py2.5.egg
\reviewboard\scmtools\models.py", line 43, in get_scmtool
    return cls(self)
  File "c:\python25\lib\site-packages\ReviewBoard-1.0.5.1-py2.5.egg
\reviewboard\scmtools\svn.py", line 49, in __init__
    import pysvn
  File "C:\Python25\lib\site-packages\pysvn\__init__.py", line 99, in
<module>
    import _pysvn_2_5
ImportError: DLL load failed: The specified procedure could not be
found.

The following is installed:
py25-pysvn-svn161-1.7.0-1177
with Python 2.5

any ideas?



On Feb 25, 3:53 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Glad it works :)
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
> On Wed, Feb 24, 2010 at 8:49 PM, danielc <co.dan...@gmail.com> wrote:
> > Christian, Thanks you SO much! You Rock!
> > It works. Just in case someone else needs it. Here is the final
> > httpd.conf:
>
> > ----------------------------------------------------------------------------------------------------------------------------------
> >         Alias /reviews/media "c:/reviewboard/htdocs/media"
> >        Alias /reviews/errordocs "c:/reviewboard/htdocs/errordocs"
>
> >        <Location "/reviews/">.
> >        Options Indexes FollowSymLinks ExecCGI
> >        AllowOverride All
>
> >    Order allow,deny
> >    Allow from all
>
> >        PythonPath "['c:/reviewboard/conf'] + sys.path"
> >                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> >                SetEnv PYTHON_EGG_CACHE "c:/reviewboard/tmp/egg_cache"
> >                SetHandler mod_python
> >                PythonHandler django.core.handlers.modpython
> >                PythonAutoReload Off
> >                PythonDebug Off
> >                # Used to run multiple mod_python sites in the same apache
> >                PythonInterpreter reviewboard_reviewboard
> >        </Location>
>
> > <Location "/reviews/media">
> >        SetHandler None
> > </Location>
> > <Location "/reviews/errordocs">
> >        SetHandler None
> > </Location>
>
> > ----------------------------------------------------------------------------------------------------------------------------------
> > Going to have a play with it now
>
> > On Feb 25, 3:41 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > Try removing the Alias for /reviews/ and adding back the media and
> > errordocs
> > > ones.
>
> > > Christian
>
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.reviewboard.org
> > > VMware, Inc. -http://www.vmware.com
>
> > > On Wed, Feb 24, 2010 at 8:30 PM, danielc <co.dan...@gmail.com> wrote:
> > > > THANK YOU!
> > > > OK, good and bad news.
> > > > Good: it seems to work now. I can login and access
> > > >http://maskfp01/reviews/account/preferences/?next=/reviews/dashboard/
>
> > > > BAD. it's doesn't display any images or anything for the media folder.
> > > > I Get 404 not found error for them.
>
> > > > from my new  httpd.conf:
>
> > ----------------------------------------------------------------------------------------------------------------------------------
> > > >         Alias /reviews/ "c:/reviewboard/htdocs"
> > > > #       Alias /reviews/media "c:/reviewboard/htdocs/media"
> > > > #       Alias /reviews/errordocs "c:/reviewboard/htdocs/errordocs"
>
> > > >         <Location "/reviews/">.
> > > >         Options Indexes FollowSymLinks ExecCGI
> > > >        AllowOverride All
>
> > > >    Order allow,deny
> > > >    Allow from all
>
> > > >        PythonPath "['c:/reviewboard/conf'] + sys.path"
> > > >                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> > > >                SetEnv PYTHON_EGG_CACHE "c:/reviewboard/tmp/egg_cache"
> > > >                SetHandler mod_python
> > > >                PythonHandler django.core.handlers.modpython
> > > >                PythonAutoReload Off
> > > >                PythonDebug Off
> > > >                # Used to run multiple mod_python sites in the same
> > apache
> > > >                PythonInterpreter reviewboard_reviewboard
> > > >         </Location>
>
> > > > <Location "/reviews/media">
> > > >        SetHandler None
> > > > </Location>
> > > > <Location "/reviews/errordocs">
> > > >        SetHandler None
> > > > </Location>
>
> > ----------------------------------------------------------------------------------------------------------------------------------
>
> > > > On Feb 25, 2:26 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > > Yeah, it's the directory setup that's probably biting you. You
> > probably
> > > > > shouldn't use <Directory> for this. I think you can use <Location>,
> > but I
> > > > > don't have a config file handy to test with this.
>
> > > > > Try placing the Python-related stuff inside a <Location "/reviews/">.
>
> > > > > Christian
>
> > > > > --
> > > > > Christian Hammond - chip...@chipx86.com
> > > > > Review Board -http://www.reviewboard.org
> > > > > VMware, Inc. -http://www.vmware.com
>
> > > > > On Wed, Feb 24, 2010 at 6:32 PM, danielc <co.dan...@gmail.com>
> > wrote:
> > > > > > Christian, Thanks for your response.
> > > > > > Yes,that is still the case. It's the most "successful" config so
> > far.
> > > > > > Should I try something else ?
>
> > > > > > Do you mean apache-modpython.conf ?
> > > > > > If so, here  it is:
>
> > -----------------------------------------------------------------------------------------------------------------------------------------------------
> > > > > > <VirtualHost *:80>
> > > > > >        ServerName maskfp01
> > > > > >         DocumentRoot "c:/reviewboard/htdocs"
>
> > > > > >        # Error handlers
> > > > > >        ErrorDocument 500 /errordocs/500.html
>
> > > > > >        # Serve django pages
> > > > > >        <Location "/reviews/">
> > > > > >                PythonPath "['c:/reviewboard/conf'] + sys.path"
> > > > > >                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> > > > > >                SetEnv PYTHON_EGG_CACHE
> > "c:/reviewboard/tmp/egg_cache"
> > > > > >                SetHandler mod_python
> > > > > >                PythonHandler django.core.handlers.modpython
> > > > > >                PythonAutoReload Off
> > > > > >                PythonDebug Off
> > > > > >                # Used to run multiple mod_python sites in the same
> > > > apache
> > > > > >                PythonInterpreter reviewboard_reviewboard
> > > > > >        </Location>
>
> > > > > >        # Serve static media without running it through mod_python
> > > > > >        # (overrides the above)
> > > > > >        <Location "/reviews/media">
> > > > > >                SetHandler None
> > > > > >        </Location>
> > > > > >        <Location "/reviews/errordocs">
> > > > > >                SetHandler None
> > > > > >        </Location>
>
> > > > > >        <Directory "c:/reviewboard/htdocs">
> > > > > >                AllowOverride All
> > > > > >        </Directory>
>
> > > > > >        # Alias static media requests to filesystem
> > > > > >        Alias /reviews/media "c:/reviewboard/htdocs/media"
> > > > > >        Alias /reviews/errordocs "c:/reviewboard/htdocs/errordocs"
> > > > > > </VirtualHost>
>
> > -----------------------------------------------------------------------------------------------------------------------------------------------------
>
> > > > > > and httpd.conf:
>
> > -----------------------------------------------------------------------------------------------------------------------------------------------------
> > > > > > #
> > > > > > # This is the main Apache HTTP server configuration file.  It
> > contains
> > > > > > the
> > > > > > # configuration directives that give the server its instructions.
> > > > > > # See <URL:http://httpd.apache.org/docs/2.2/> for detailed
> > > > > > information.
> > > > > > # In particular, see
> > > > > > # <URL:http://httpd.apache.org/docs/2.2/mod/directives.html>
> > > > > > # for a discussion of each configuration directive.
> > > > > > #
> > > > > > # Do NOT simply read the instructions in here without understanding
> > > > > > # what they do.  They're here only as hints or reminders.  If you
> > are
> > > > > > unsure
> > > > > > # consult the online docs. You have been warned.
> > > > > > #
> > > > > > # Configuration and logfile names: If the filenames you specify for
> > > > > > many
> > > > > > # of the server's control files begin with "/" (or "drive:/" for
> > > > > > Win32), the
> > > > > > # server will use that explicit path.  If the filenames do *not*
> > begin
> > > > > > # with "/", the value of ServerRoot is prepended -- so
> > "logs/foo.log"
> > > > > > # with ServerRoot set to "C:/Program Files/Apache Software
> > Foundation/
> > > > > > Apache2.2" will be interpreted by the
> > > > > > # server as "C:/Program Files/Apache Software Foundation/Apache2.2/
> > > > > > logs/foo.log".
> > > > > > #
> > > > > > # NOTE: Where filenames are specified, you must use forward slashes
> > > > > > # instead of backslashes (e.g., "c:/apache" instead of
> > "c:\apache").
> > > > > > # If a drive letter is omitted, the drive on which Apache.exe is
> > > > > > located
> > > > > > # will be used by default.  It is recommended that you always
> > supply
> > > > > > # an explicit drive letter in absolute paths, however, to avoid
> > > > > > # confusion.
> > > > > > #
>
> > > > > > # ThreadsPerChild: constant number of worker threads in the server
> > > > > > process
> > > > > > # MaxRequestsPerChild: maximum  number of requests a server process
> > > > > > serves
> > > > > > ThreadsPerChild 250
> > > > > > MaxRequestsPerChild  0
>
> > > > > > #
> > > > > > # ServerRoot: The top of the directory tree under which the
> > server's
> > > > > > # configuration, error, and log files are kept.
> > > > > > #
> > > > > > # Do not add a slash at the end of the directory path.  If you
> > point
> > > > > > # ServerRoot at a non-local disk, be sure to point the LockFile
> > > > > > directive
> > > > > > # at a local disk.  If you wish to share the same ServerRoot for
> > > > > > multiple
> > > > > > # httpd daemons, you will need to change at least LockFile and
> > > > > > PidFile.
> > > > > > #
> > > > > > ServerRoot "C:/Program Files/Apache Software Foundation/Apache2.2"
>
> > > > > > #
> > > > > > # Listen: Allows you to bind Apache to specific IP addresses and/or
> > > > > > # ports, instead of the default. See also the <VirtualHost>
> > > > > > # directive.
> > > > > > #
> > > > > > # Change this to Listen on specific IP addresses as shown below to
> > > > > > # prevent Apache from glomming onto all bound IP addresses
> > (0.0.0.0)
> > > > > > #
> > > > > > #Listen 12.34.56.78:80
> > > > > > Listen 80
>
> > > > > > #
> > > > > > # Dynamic Shared Object (DSO) Support
> > > > > > #
> > > > > > # To be able to use the functionality of a module which was built
> > as a
>
> ...
>
> read more »

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to