Hi Daniel,

Totally missed your updates. Sorry about that.

You mentioned using <Directory> instead of <VirtualHost>. Is that still the
case? Would you mind attaching your httpd.conf and your Review Board vhost
conf?

This definitely sounds like an Apache config issue and not a Review Board
code issue.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Wed, Feb 24, 2010 at 4:53 PM, danielc <co.dan...@gmail.com> wrote:

> Any ideas anyone ??
>
> On Feb 18, 10:25 am, danielc <co.dan...@gmail.com> wrote:
> > I just remembered I did manage to get the "Manual Server updates"
> > which indicated I should put patch.exe in the PATH.
> > After putting adding it to the path, I got the forbidden messages
> > again.
> > Notes that this was using my own httpd.conf hack with a <Directory>
> > instead of a <VirtualHost >.
> >
> > On Feb 18, 10:10 am, danielc <co.dan...@gmail.com> wrote:
> >
> > > Hi Chris,
> > > Thanks for your quick reply!
> > > No, I've never seen the reviewbaord site, just forbidden messages.
> >
> > > The version is: 1.0.5.1
> >
> > > BTW, It's a Windows 2003 server
> >
> > > On Feb 17, 7:12 pm, Christian Hammond <chip...@chipx86.com> wrote:
> >
> > > > Hi Daniel,
> >
> > > > That review request for subdirectory support is pretty ancient. We've
> > > > supported it for a long time now. It looks like that config file was
> > > > generated with /reviews set as the subdirectory successfully.
> >
> > > > The configuration looks good. When you initially went to /reviews/,
> you saw
> > > > the Review Board site, right? It looks like you were logged in
> successfully,
> > > > so it's just the dashboard that is for some reason being blocked,
> though I
> > > > don't see anything in the code that should cause that.
> >
> > > > What version of Review Board did you install?
> >
> > > > Christian
> >
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
> >
> > > > On Tue, Feb 16, 2010 at 10:32 PM, danielc <co.dan...@gmail.com>
> wrote:
> > > > > Right now, Accessing:http://server/reviews/
> > > > > redirects to:
> > > > >http://server/reviews/dashboard/
> > > > > which gives a 403 forbidden error (not a a 404 not found error)
> >
> > > > > Setup:
> > > > > Apache 2.2.4
> > > > > Python 2.5.4
> > > > > mod_python 3.3.1
> > > > > MySQL-python 1.2.2
> > > > > pysvn 1.7.0
> >
> > > > > This is the apache-modpython.conf which was generated:
> >
> > > > >
> ----------------------------------------------------------------------------------------------
> > > > > <VirtualHost *:80>
> > > > >        ServerName server
> > > > >        DocumentRoot "c:/reviewboard/htdocs"
> >
> > > > >        # Error handlers
> > > > >        ErrorDocument 500 /errordocs/500.html
> >
> > > > >        # Serve django pages
> > > > >        <Location "/reviews/">
> > > > >                PythonPath "['c:/reviewboard/conf'] + sys.path"
> > > > >                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> > > > >                SetEnv PYTHON_EGG_CACHE
> "c:/reviewboard/tmp/egg_cache"
> > > > >                SetHandler mod_python
> > > > >                PythonHandler django.core.handlers.modpython
> > > > >                PythonAutoReload Off
> > > > >                PythonDebug Off
> > > > >                # Used to run multiple mod_python sites in the same
> apache
> > > > >                PythonInterpreter reviewboard_reviewboard
> > > > >        </Location>
> >
> > > > >        # Serve static media without running it through mod_python
> > > > >        # (overrides the above)
> > > > >        <Location "/reviews/media">
> > > > >                SetHandler None
> > > > >        </Location>
> > > > >        <Location "/reviews/errordocs">
> > > > >                SetHandler None
> > > > >        </Location>
> >
> > > > >        <Directory "c:/reviewboard/htdocs">
> > > > >                AllowOverride All
> > > > >        </Directory>
> >
> > > > >        # Alias static media requests to filesystem
> > > > >        Alias /reviews/media "c:/reviewboard/htdocs/media"
> > > > >        Alias /reviews/errordocs "c:/reviewboard/htdocs/errordocs"
> > > > > </VirtualHost>
> >
> > > > >
> ---------------------------------------------------------------------------------------------
> > > > > It didn't really get me anywhere so I've tried the add this to
> > > > > httpd.conf instead:
> >
> > > > >
> ---------------------------------------------------------------------------------------------
> > > > >        Alias /reviews/ "c:/reviewboard/htdocs"
> > > > > <Directory "c:/reviewboard/htdocs">
> > > > >        Options Indexes FollowSymLinks ExecCGI
> > > > >        AllowOverride All
> >
> > > > >    Order allow,deny
> > > > >    Allow from all
> >
> > > > >        PythonPath "['c:/reviewboard/conf'] + sys.path"
> > > > >                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
> > > > >                SetEnv PYTHON_EGG_CACHE
> "c:/reviewboard/tmp/egg_cache"
> > > > >                SetHandler mod_python
> > > > >                PythonHandler django.core.handlers.modpython
> > > > >                PythonAutoReload Off
> > > > >                PythonDebug Off
> > > > >                # Used to run multiple mod_python sites in the same
> apache
> > > > >                PythonInterpreter reviewboard_reviewboard
> > > > > </Directory>
> >
> > > > >
> ------------------------------------------------------------------------------------------------------------------------------
> >
> > > > > I've been looking everywhere for solution, and ran into this review
> > > > > which suggests the newer builds should support installing into a
> > > > > subdirectory, but it doesn't really say how:
> > > > >http://reviews.reviewboard.org/r/235/
> >
> > > > > Would greatly appreciate any help. Please tell me if the
> information
> > > > > I've provided is insufficient
> > > > > thanks,
> > > > > Daniel
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to