If Your system is Windows You must do this in two steps. Windows: SET HTTP_PROXY=http://your-proxy:port/ easy_install ReviewBoard
Linux another way: export http_proxy=http://your-proxy:port/ export HTTP_PROXY=http://yoour-proxy:port/ easy_install ReviewBoard On Mon, Jul 26, 2010 at 5:42 AM, kuripot <[email protected]> wrote: > When I try that string I get 'env' is not recognized as an internal or > external command. If I remove 'env' I get the same error message for > 'http_proxy' or 'HTTP_PROXY'. > > Extra info: The system is on a windows domain and accesses the web via > proxy and username:password authentication. > > Thanks again > On Jul 25, 2:03 am, Jan Koprowski <[email protected]> wrote: >> env http_proxy=http://your-proxy:port/easy_install reviewboard >> >> or >> >> env HTTP_PROXY=http://your-proxy:port/easy_install reviewboard >> >> >> >> On Sun, Jul 25, 2010 at 5:53 AM, kuripot <[email protected]> wrote: >> > Ok... back to square one on a different server... decided to go with >> > lighttpd instead of apache. I can confirm that lighttpd is >> > functional... however I'd like to know how I can set my proxy >> > parameters. easy_install reviewboard fails... >> >> > no local packages or download links found for... everytime it tries to >> > get a package. >> >> > thanks >> >> > On Jul 22, 12:05 pm, kuripot <[email protected]> wrote: >> >> Not sure this is the right place for this question... >> >> Still can't get ReviewBoard to work due to Apache settings. >> >> >> When I test the configuration I get an error message stating that it >> >> could not bind to address 0.0.0.0:80 >> >> No listening sockets available. >> >> >> Running netstat -ano I can tell that process ID 4 (system process) is >> >> listening on that port. >> >> >> When I try to change the "listen port" in httpd.conf to any other >> >> number (90, 8080, 81, etc.) I still get the same fail error. >> >> When I run netstat, I see that process ID 4 is still listening to port >> >> 80 and that Apache is listening to port 90 (or whatever number I >> >> change it to). >> >> However it still fails when testing the configuration. >> >> >> Tried 127.0.0.1, nameOfServer.domain_name (with and without the port >> >> number). >> >> >> Running Server 2008 R2. Enabling or disabling firewall makes no >> >> difference. Stopping WAS and W3SVC makes no difference as well. >> >> >> Any suggestions? >> >> >> On Jul 21, 3:38 pm, Christian Hammond <[email protected]> wrote: >> >> >> > Glad it's installed :) Let us know if there are any further problems. >> >> >> > Christian >> >> >> > -- >> >> > Christian Hammond - [email protected] >> >> > Review Board -http://www.reviewboard.org >> >> > VMware, Inc. -http://www.vmware.com >> >> >> > On Wed, Jul 21, 2010 at 12:35 PM, kuripot <[email protected]> wrote: >> >> > > Thanks. Actually, django evolution was fine... the issue was with >> >> > > Django... I ran setup.py install again and it worked. Not sure why it >> >> > > didn't the first time around. >> >> > > Note that I installed everything manually so the sequence of how the >> >> > > dependencies were installed could be the cause... not sure. >> >> >> > > I now get Performing migrations... no evolution required. Looking >> >> > > forward to trying ReviewBoard... >> >> >> > > Mike >> >> >> > > On Jul 21, 3:32 pm, Christian Hammond <[email protected]> wrote: >> >> > > > Sounds like the django_evolution package wasn't properly installed. >> >> > > > You >> >> > > can >> >> > > > get this with: >> >> >> > > > easy_install -U django_evolution >> >> >> > > > Christian >> >> >> > > > -- >> >> > > > Christian Hammond - [email protected] >> >> > > > Review Board -http://www.reviewboard.org >> >> > > > VMware, Inc. -http://www.vmware.com >> >> >> > > > On Wed, Jul 21, 2010 at 12:12 PM, kuripot <[email protected]> >> >> > > > wrote: >> >> > > > > We had a similar issue... your guess was right. Once the db was >> >> > > > > created it went through... almost to the end... >> >> >> > > > > The current error we are now getting is >> >> > > > > ... >> >> > > > > Performing migrations ... Unknown command: 'evolve' >> >> > > > > Type 'rbsite.pyc help' for usage. >> >> >> > > > > Thanks for any help... >> >> > > > > Mike >> >> >> > > > > On Jul 21, 1:33 pm, Stephen Gallagher <[email protected]> >> >> > > > > wrote: >> >> > > > > > On 07/21/2010 12:19 PM, Peter Michelakis wrote: >> >> >> > > > > > > Hi, >> >> >> > > > > > > Trying to setup reviewboard for the first time... I was >> >> > > > > > > unable to >> >> > > run >> >> > > > > > > easy_install to get all the packages (might be due to proxy >> >> > > settings). >> >> > > > > > > I therefore downloaded all the dependencies and ran the setup >> >> > > > > > > on >> >> > > each >> >> > > > > > > of them. I'm now at the reviewboard installation and I'm >> >> > > > > > > getting >> >> > > > > > > failures at the database creation level: >> >> > > > > > > <snip> >> >> > > > > > > _mysql_exceptions.OperationalError: (1049, "Unknown database >> >> > > > > > > 'reviewboard'") >> >> >> > > > > > My guess is that you didn't create the database in mysql first. >> >> > > rb-site >> >> > > > > > doesn't create the DB, it just populates an empty one. >> >> >> > > > > -- >> >> > > > > Want to help the Review Board project? Donate today at >> >> > > > >http://www.reviewboard.org/donate/ >> >> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/ >> >> > > > > -~----------~----~----~----~------~----~------~--~--- >> >> > > > > To unsubscribe from this group, send email to >> >> > > > > [email protected]<reviewboard%[email protected]> >> >> > > <reviewboard%[email protected]<reviewboard%[email protected]> >> >> >> > > > > For more options, visit this group at >> >> > > > >http://groups.google.com/group/reviewboard?hl=en >> >> >> > > -- >> >> > > Want to help the Review Board project? Donate today at >> >> > >http://www.reviewboard.org/donate/ >> >> > > Happy user? Let us know athttp://www.reviewboard.org/users/ >> >> > > -~----------~----~----~----~------~----~------~--~--- >> >> > > To unsubscribe from this group, send email to >> >> > > [email protected]<reviewboard%[email protected]> >> >> > > For more options, visit this group at >> >> > >http://groups.google.com/group/reviewboard?hl=en >> >> > -- >> > Want to help the Review Board project? Donate today >> > athttp://www.reviewboard.org/donate/ >> > Happy user? Let us know athttp://www.reviewboard.org/users/ >> > -~----------~----~----~----~------~----~------~--~--- >> > To unsubscribe from this group, send email to >> > [email protected] >> > For more options, visit this group >> > athttp://groups.google.com/group/reviewboard?hl=en >> >> -- >> >> ><> Jan Koprowski >> >> > > -- > Want to help the Review Board project? Donate today at > http://www.reviewboard.org/donate/ > Happy user? Let us know at http://www.reviewboard.org/users/ > -~----------~----~----~----~------~----~------~--~--- > To unsubscribe from this group, send email to > [email protected] > For more options, visit this group at > http://groups.google.com/group/reviewboard?hl=en -- ><> Jan Koprowski -- Want to help the Review Board project? Donate today at http://www.reviewboard.org/donate/ Happy user? Let us know at http://www.reviewboard.org/users/ -~----------~----~----~----~------~----~------~--~--- To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/reviewboard?hl=en
