I'm using Mercurial 3.0, ReviewBoard 2.0.1 and as of today, the latest code
from https://bitbucket.org/ccaughie/hgreviewboard . I did forget to add "hg
add file2.txt" to the list of steps, but I ran it during testing.   Should
the code figure out which revision to use for the parent diff base? It
works if I specify "--master qparent".


On Wed, Jun 4, 2014 at 4:36 PM, Colin Caughie <c.caug...@gmail.com> wrote:

>  Following those instructions exactly I get an error message of "The
> specified diff file is empty", which is not surprising since file2.txt was
> never added to the repository.
> If I do "hg add file2.txt" before the first qnew on the other hand, "hg
> postreview" works fine and correctly shows Line2 being added to file2.txt.
> If it is still breaking for you even with the hg add, can you let me know
> what versions of mercurial, ReviewBoard and the reviewboard extension
> you're using?
> If you're using the latest versions and it still doesn't work, please send
> me the output of
> hg postreview --debug --apitrace

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to