Christian,

Thanks for the quick response.

1. I don't need or want subvertpy.  I just noticed that the error was in 
pysvn.  I'll stick with what you guys have determined works best; i.e., 
pysvn.

2. I created the site directory from scratch, but then tried to find stuff 
from the backup site directory to tweak.  The only thing that looked 
interesting was the uploaded/files content, which I ended up copying to the 
new server.

3. I don't remember ever setting passwords for the repositories.  I see 
what I guess is encrypted passwords in the scmtools_repository table.  They 
are encrypted and do *not* start with a tab, so I guess that is the problem.

How do I change them again?   If I go into "Repositories" as the admin and 
click on a repository, I get the same error.  Can I change them directly in 
the database (as plain text)?


On Thursday, July 30, 2015 at 3:25:33 PM UTC-4, Christian Hammond wrote:
>
> Hi David,
>
> First, to cover the PySVN vs. Subvertpy question, Subvertpy was only the 
> default for the first release or two of 2.0.x. It had a lot of 
> compatibility problems and broke in far too many situations, so we flipped 
> the defaults. If it was working for you and you want to go back to it, you 
> can set the following in settings_local.py:
>
> SVNTOOL_BACKENDS = [
>     'reviewboard.scmtools.svn.subvertpy',
>     'reviewboard.scmtools.svn.pysvn',
> ]
>
> Alright, on to the problem at hand.
>
> Passwords for repositories are stored encrypted. Perhaps something went 
> wrong between the dump and restore that broke this. Can you check your dump 
> file and the contents in the database for the repository 
> (scmtools_repository table) to see if it's the expected password in plain 
> text, or if it's something encrypted that starts with a tab character? If 
> it's neither, that's the problem.
>
> You can, in this case, change the stored password in the repository to 
> your plain text password. The next time Review Board reads the password in 
> for the repository, it will re-encrypt it.
>
> One more thing: Did you copy over the old site directory, or create a new 
> one from scratch?
>
> Christian
>
> -- 
> Christian Hammond - chi...@chipx86.com <javascript:>
> Review Board - https://www.reviewboard.org
> Beanbag, Inc. - https://www.beanbaginc.com
>
> On Thu, Jul 30, 2015 at 11:18 AM, David Carson <dcca...@gmail.com 
> <javascript:>> wrote:
>
>> I'm trying to restore a ReviewBoard server after a hardware system 
>> failure.  This is a live system and I'm under pressure to get it back up.  
>> I'm very close to having it working, but I'm hitting a UnicodeDecodeError. 
>>  (Yes, I know there are other topics on this forum regarding 
>> UnicodeDecodeError, but none of them seem quite the same as mine.)
>>
>> The new server is running 2.0.18.  The old server was running 2.0.15.  I 
>> think this may be part of the problem.
>>
>>
>>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to