Hi David,

Been in meetings. Sorry for not getting back to you sooner.

That's odd. If you get a 500, it should definitely appear in the log. What
you can try doing if that's not happening is *temporarily* setting this in
your $sitedir/conf/settings_local.py:

    DEBUG = True

(This *will* change behavior of the site, so remove it when done with this

Reload the web server and go back to that repository. You should get a
detailed traceback now, along with all the variables at each point in the


Christian Hammond - chip...@chipx86.com
Review Board - https://www.reviewboard.org
Beanbag, Inc. - https://www.beanbaginc.com

On Thu, Jul 30, 2015 at 1:46 PM, David Carson <dccar...@gmail.com> wrote:

> OK, progress.
> I edited my SQL dump file, replacing the tab-initial-character-encrypted
> passwords with plain-text passwords.  Not sure what they used to be, so I
> just put something simple.  Then I dropped the reviewboard database and
> recreated it as utf8, and loaded the edited dump file.
> Now I can successfully navigate to review requests.  Have not tried
> anything more complicated on the user side yet.
> I also tried to click on a repository as the admin user (
> http://reviewboard.mycompany.com/admin/db/scmtools/repository/) and I get
> the '500' error.  However, I am not getting anything in the log this time.
> So, based on this, I'm not quite sure what else might be broken.  I'm a
> bit hesitant to advertise that the server is online again (already did that
> once), until I'm more confident that users won't be hitting more problems.
> For now, I'd like to understand why I get no log output and what the error
> actually is for the repository links.
> Thanks.
> On Thursday, July 30, 2015 at 4:01:31 PM UTC-4, David Carson wrote:
>> Sorry, I was wrong.  All repository passwords do start with 0x09.  I was
>> not looking at them correctly.
>> On Thursday, July 30, 2015 at 3:58:09 PM UTC-4, David Carson wrote:
>>> 3. I don't remember ever setting passwords for the repositories.  I see
>>> what I guess is encrypted passwords in the scmtools_repository table.  They
>>> are encrypted and do *not* start with a tab, so I guess that is the
>>> problem.

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to