Some additional information after further experimentation:

* I tried upgrading from the same 1.7.27 database to 2.0.18. This worked 
perfectly fine. I ran compressdiffs afterwards as suggested, that worked 
* I then tried upgrading from 2.0.18 to 2.5.2, but got the same "Can't 
create table 'reviewboard.#xxxx'" error.

Next I scripted the upgrade from 1.7.27 to 2.5.2, and tried a few 
variations, including location of the database, etc.
The process is:
1) Create empty database
2) Restore my 1.7.27 database
3) Run rb-site upgrade

That reliably triggers the "Can't create table" error. However, if I add 
one step:
1) Create empty database
1.5) Run rb-site install
2) Restore my 1.7.27 database
3) Run rb-site upgrade

Then the "Can't create table" error is avoided, and it manages to apply 
many django evolutions. Eventually it fails with:
CommandError: Error applying evolution: (1050, "Table 
'reviews_reviewrequest_file_attachment_histories' already exists")
which is not entirely unexpected since I ran rb-site install which likely 
created that table.

I am using mariadb-5.5.44 on CentOS 7.1.


Supercharge your Review Board with Power Pack:
Want us to host Review Board for you? Check out RBCommons:
Happy user? Let us know!
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to