> On 十月 22, 2015, 3:08 a.m., Guangya Liu wrote:
> > src/master/http.cpp, line 839
> > <https://reviews.apache.org/r/36913/diff/19/?file=1102864#file1102864line839>
> >
> >     what about "return quotaHandler.create(request)"
> 
> Joerg Schad wrote:
>     Wanted to make names consistent.
>     @alex: any preference?
> 
> Alexander Rukletsov wrote:
>     Yes. Naming is hard, we had a long offline discussion about these names 
> and decided the following:
>     - Be consistent. Though there are subtle differences between operations 
> depending on the stage in the process, they are minor and will most probably 
> lead to confusion.
>     - `set` instead of `add`, `request`, or `create`. You cannot call `set` 
> multiple times, that's why `add` is not good. `request` is too vague, you can 
> request anything. `create` carries the meaning of a creation act, which is 
> not the focus we would like to have. An important message to deliver is that 
> `set` my change the allocation behaviour for the role significantly.
>     - `update` (not in MVP).
>     - `remove` instead of `release`, `destroy`, or `delete`. `destroy` and 
> `delete` focus on scrapping an object, which is not the most important action 
> in this case. We would like to put accent on the fact that there is no more 
> quota associated with the role. `release` for me implies possession, 
> moreover, it doesn't play nice with `set`.
>     - CRUD naming is a reasonable alternative (because it's a standard), 
> however we decided to opt for more specific naming in a hope it will help 
> understanding quota implications better.
>     - This is all about internal naming, the operator API uses standard HTTP 
> verbs for these actions.

Thanks Alex, fair enough.


- Guangya


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36913/#review103518
-----------------------------------------------------------


On 十月 22, 2015, 1:03 a.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36913/
> -----------------------------------------------------------
> 
> (Updated 十月 22, 2015, 1:03 a.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Bernd Mathiske, Alex Clemmer, 
> and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-3073
>     https://issues.apache.org/jira/browse/MESOS-3073
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added /quota HTTP Endpoint for Quota handling.
> 
> 
> Diffs
> -----
> 
>   src/CMakeLists.txt e6169a0e3ad34dd0e4c3430a6532bd48c4bd04fd 
>   src/Makefile.am 98cbafc134ec388a176d50172912fbfdf9f5bfa3 
>   src/master/http.cpp 093f79384916dc08b32b70d3614e0ff314825c42 
>   src/master/master.hpp e7b16fdd21a8caa77a39956a8520cf1381186598 
>   src/master/master.cpp 0981428f5a93242d6fb3f68fb93d5f8ee6178ace 
>   src/master/quota_handler.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/36913/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>

Reply via email to