> On Sept. 17, 2016, 4:11 a.m., Jie Yu wrote:
> > 3rdparty/libprocess/include/process/subprocess_base.hpp, lines 402-403
> > <https://reviews.apache.org/r/45491/diff/4/?file=1495705#file1495705line402>
> >
> >     Hum, i don't like ChildHook::None(). Have you tried if ```const 
> > vector<ChildHook>& child_hooks = {}``` works or not?
> 
> Joerg Schad wrote:
>     This is currently consistent with Hook::None(). Do you have a strong 
> opinion?
> 
> Jie Yu wrote:
>     Yeah, I'd like to cleanup Hook::None() as well. This caused some 
> confusion to me before. You can clean up the Hook::None() in a separate patch.

https://reviews.apache.org/r/52015/
https://reviews.apache.org/r/52016/


> On Sept. 17, 2016, 4:11 a.m., Jie Yu wrote:
> > 3rdparty/libprocess/include/process/subprocess_base.hpp, line 314
> > <https://reviews.apache.org/r/45491/diff/4/?file=1495705#file1495705line314>
> >
> >     I suggest we rename Hook to ParentHook. You can do that in a separate 
> > patch.
> 
> Joerg Schad wrote:
>     Sound good. Will be done in a seperate patch.

https://reviews.apache.org/r/52017/
https://reviews.apache.org/r/52018/


- Joerg


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45491/#review149318
-----------------------------------------------------------


On Sept. 18, 2016, 7:43 p.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45491/
> -----------------------------------------------------------
> 
> (Updated Sept. 18, 2016, 7:43 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov and Jie Yu.
> 
> 
> Bugs: MESOS-5070
>     https://issues.apache.org/jira/browse/MESOS-5070
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Previously the subprocess interface supported a several options for the
> child process such as setsid. In order to make the interface more
> flexible we refactored such options into a vector of ChildHooks.
> In order not to allow arbitrary code inside a ChildHook it has to be
> constructed via pre-defined factory methods.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/posix/subprocess.hpp 
> 57f71d15e6fbb032c8b6c5d0c73a93751022e7e7 
>   3rdparty/libprocess/include/process/ssl/gtest.hpp 
> 2ad623a5ea3b3286983e895010af756f14f51b64 
>   3rdparty/libprocess/include/process/subprocess_base.hpp 
> acd23c99162f164c02a7781abeb95b3c220ead12 
>   3rdparty/libprocess/src/subprocess.cpp 
> 8ca61f77083ac4b77aa1aec22806e1be43dbfa6c 
>   3rdparty/libprocess/src/tests/subprocess_tests.cpp 
> 0ff3945d2c722ebc1529265427397c5dfba6854e 
> 
> Diff: https://reviews.apache.org/r/45491/diff/
> 
> 
> Testing
> -------
> 
> Tested entire chain see https://reviews.apache.org/r/45492.
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>

Reply via email to