Regarding the problem playing a piece in Rosegarden where the position doesn't advance, I did more testing.

I have tried it on four different machines I have upgraded to Lubuntu 16.10, and the problem where the current position in the sequence doesn't advance is the same in all of them.

In the Rosegarden preferences, the timer was set to "auto".

I tried setting it to other things, such as "system" (the 1st entry) - no change. "EMU10K1" - no change. "HR Timer" - hung the system, and had to power-off.

I am out of ideas on this problem.

I was able to export the most demanding of my "MIDI Stress Test" files as a MIDI file (from Rosegarden), and played it using the KeyMusician Keyboard MIDI Player (using Qsynth), and the system passed the test - no audio drop-outs - even in the slow (933 megahertz) machine.

I just can't play anything using Rosegarden 16.06 on any of my Ubuntu 16.10 systems.

- Aere

On 10/15/2016 12:00 PM, Aere Greenway wrote:
Apparently there is some backward-compatibility problem loading Rosegarden ('.rg') files saved in prior versions of Rosegarden.

All of the several '.rg' files that cause Rosegarden to crash when loading them, can be loaded and played using version 15.12 of Rosegarden. But when you try to load them with version 16.06, a crash occurs.

I don't know what it is about the files that causes the crash. Some are complex, and some are simple.

I have attached a fairly simple '.rg' file that crashes Rosegarden 16.06 when you attempt to load it.

Please check if it causes a crash in your test systems.

I still don't know why the sequence position fails to advance when using Ubuntu 16.10. When I play the same pieces on Ubuntu 16.04 (using Rosegarden 16.06), the sequence position advances properly.

I will investigate this other problem further, and let you know what I find.

- Aere

On 10/15/2016 11:03 AM, Aere Greenway wrote:
On 10/15/2016 10:47 AM, Aere Greenway wrote:
The version of Rosegarden in the Ubuntu repository for release 16.10 has not worked on every machine I have so far tested it on (both 64-bit, and

The Rosegarden versios is 16.06 "Rhapsody In Blue" (as I recall).

It crashes the first time you attempt to load a file (leaving it
locked), but thereafter can load successfully other files (after
re-loading Rosegarden).

But when you go to play the loaded sequence, the position in the
sequence does not advance.

I can set the position within the sequence, and hit the play button, and
the notes there will start playing, but never end.

The transport window shows fractions of the current beat changing, but
the position never moves.

I noticed the same problem with the '.rg' files I normally test, with on
the same version of Rosegarden I got from the Debian repository.

However, it had no problem loading and playing another sequence ('.rg'

It appears to be something related to the files I've been using for
testing (I use them because they really load-down the system). I have
used them successfully for testing Rosegarden in all past Ubuntu releases.

I will investigate this problem further, and let you all know what I find.

Check out the vibrant tech community on one of the world's most
engaging tech sites,!

Rosegarden-devel mailing list - use the link below to unsubscribe


Check out the vibrant tech community on one of the world's most 
engaging tech sites,!
Rosegarden-devel mailing list - use the link below to unsubscribe

Reply via email to