Re: RFR: JDK-8262471: Fix coding style in src/java.base/share/classes/java/lang/CharacterDataPrivateUse.java

2021-03-10 Thread Christoph Göttschkes
On Mon, 1 Mar 2021 15:21:23 GMT, Christoph Göttschkes wrote: >> Looks fine. This source file was a .template until a few weeks ago, probably >> should have fixed the indentation issues when moving it to a .java file. > > Thanks for the review. > Do we need a second reviewer? If not, could you

Re: RFR: JDK-8248904: Add support to jpackage for the Mac App Store

2021-03-10 Thread Andy Herrick
On Wed, 10 Mar 2021 12:37:32 GMT, Kevin Rushforth wrote: >> Implementation of Mac App Support including three new mac specific CLI >> options. > > src/jdk.jpackage/share/classes/jdk/jpackage/internal/resources/HelpResources.properties > line 247: > >> 245: \ --mac-app-store\n\ >> 246: \

Re: RFR: 8263105: security-libs doclint cleanup [v2]

2021-03-10 Thread Roger Riggs
On Tue, 9 Mar 2021 00:56:25 GMT, Bradford Wetmore wrote: >> Fix various things pointed out by the most recent doclint run in the >> security-libs area. >> >> This is docs only: I will be checking doccheck/doclint, and will be running >> tier1/tier2 tests. Minor spot checks on generated

Re: RFR: 8263105: security-libs doclint cleanup [v3]

2021-03-10 Thread Roger Riggs
On Tue, 9 Mar 2021 22:19:28 GMT, Bradford Wetmore wrote: >> Fix various things pointed out by the most recent doclint run in the >> security-libs area. >> >> This is docs only: I will be checking doccheck/doclint, and will be running >> tier1/tier2 tests. Minor spot checks on generated

Re: RFR: JDK-8248904: Add support to jpackage for the Mac App Store

2021-03-10 Thread Alexander Zuev
On Wed, 24 Feb 2021 21:59:22 GMT, Andy Herrick wrote: > Implementation of Mac App Support including three new mac specific CLI > options. Marked as reviewed by kizune (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/2716

RFR: 8263358: Update java.lang to use instanceof pattern variable

2021-03-10 Thread Patrick Concannon
Hi, Could someone please review my code for updating the code in the `java.lang` package to make use of the `instanceof` pattern variable? Kind regards, Patrick - Commit messages: - 8263358: Update java.lang to use instanceof pattern variable Changes:

RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Claes Redestad
Use requireNonNull instead. - Commit messages: - Unintended use of Objects.nonNull in VarHandles Changes: https://git.openjdk.java.net/jdk/pull/2914/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk=2914=00 Issue: https://bugs.openjdk.java.net/browse/JDK-8263380 Stats:

Re: RFR: JDK-8262471: Fix coding style in src/java.base/share/classes/java/lang/CharacterDataPrivateUse.java

2021-03-10 Thread Roger Riggs
On Fri, 26 Feb 2021 17:50:19 GMT, Christoph Göttschkes wrote: > Please review this small patch which fixes the coding style of > CharacterDataPrivateUse.java For (most) core-libs changes, only 1 reviewer is required. However, given the broad interest, please allow time (a day or weekend) for

Integrated: JDK-8262471: Fix coding style in src/java.base/share/classes/java/lang/CharacterDataPrivateUse.java

2021-03-10 Thread Christoph Göttschkes
On Fri, 26 Feb 2021 17:50:19 GMT, Christoph Göttschkes wrote: > Please review this small patch which fixes the coding style of > CharacterDataPrivateUse.java This pull request has now been integrated. Changeset: c8c0234b Author:Christoph Göttschkes Committer: Roger Riggs URL:

Re: RFR: 8241716: Jpackage functionality to let users choose whether to create shortcuts [v2]

2021-03-10 Thread Andy Herrick
On Tue, 9 Mar 2021 16:50:40 GMT, Alexey Semenyuk wrote: >> Add support to insert dialog with prompts to create shortcuts in dialog >> installation sequence of Windows installers created by jpackage. >> >> Dialog look: >>

Re: RFR: JDK-8248904: Add support to jpackage for the Mac App Store

2021-03-10 Thread Kevin Rushforth
On Wed, 24 Feb 2021 21:59:22 GMT, Andy Herrick wrote: > Implementation of Mac App Support including three new mac specific CLI > options. Looks good with a couple questions. Is `JavaApp.icns` intended to be an empty file (I see that the file it was renamed from was empty, so probably OK)? The

Re: RFR: 8263358: Update java.lang to use instanceof pattern variable

2021-03-10 Thread Brian Goetz
These patches are obviously minimally correct.  However, for equals methods at least, I would take them one step further, from:     if (!(o instanceof Key that)) return false;     //noinspection StringEquality (guaranteed interned String(s))     return name == that.name

Re: RFR: JDK-8248904: Add support to jpackage for the Mac App Store

2021-03-10 Thread Andy Herrick
On Wed, 10 Mar 2021 12:37:03 GMT, Kevin Rushforth wrote: >> Implementation of Mac App Support including three new mac specific CLI >> options. > > src/jdk.jpackage/share/classes/jdk/jpackage/internal/resources/HelpResources.properties > line 188: > >> 186: \ over-ridden by adding

Re: RFR: 8263358: Update java.lang to use instanceof pattern variable

2021-03-10 Thread Claes Redestad
On Wed, 10 Mar 2021 12:59:18 GMT, Patrick Concannon wrote: > Hi, > > Could someone please review my code for updating the code in the `java.lang` > package to make use of the `instanceof` pattern variable? > > Kind regards, > Patrick Great. I included some of these in #2300 - @mlchung has

Re: RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Andrey Turbanov
On Wed, 10 Mar 2021 16:40:56 GMT, Claes Redestad wrote: >> Nice catch! >> >> We have a test that is supposed to test this: >> https://github.com/openjdk/jdk/blob/master/test/jdk/java/foreign/TestNulls.java >> But it is only checking if an NPE is thrown, and not checking for a >> message,

Re: RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Roger Riggs
On Wed, 10 Mar 2021 18:16:49 GMT, Andrey Turbanov wrote: >>> Nice catch! >>> >>> We have a test that is supposed to test this: >>> https://github.com/openjdk/jdk/blob/master/test/jdk/java/foreign/TestNulls.java >>> But it is only checking if an NPE is thrown, and not checking for a >>>

Re: RFR: 8263105: security-libs doclint cleanup [v3]

2021-03-10 Thread Sean Mullan
On Tue, 9 Mar 2021 22:19:28 GMT, Bradford Wetmore wrote: >> Fix various things pointed out by the most recent doclint run in the >> security-libs area. >> >> This is docs only: I will be checking doccheck/doclint, and will be running >> tier1/tier2 tests. Minor spot checks on generated

Re: RFR: 8263105: security-libs doclint cleanup [v3]

2021-03-10 Thread Iris Clark
On Tue, 9 Mar 2021 22:19:28 GMT, Bradford Wetmore wrote: >> Fix various things pointed out by the most recent doclint run in the >> security-libs area. >> >> This is docs only: I will be checking doccheck/doclint, and will be running >> tier1/tier2 tests. Minor spot checks on generated

Re: RFR: 8260605: Various java.lang.invoke cleanups [v5]

2021-03-10 Thread Claes Redestad
> - Remove unused code > - Inline and simplify the bootstrap method invocation code (remove pointless > reboxing checks etc) > - Apply pattern matching to make some code more readable Claes Redestad has updated the pull request with a new target base due to a merge or a rebase. The incremental

Re: RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Claes Redestad
On Wed, 10 Mar 2021 16:04:59 GMT, Jorn Vernee wrote: > Nice catch! > > We have a test that is supposed to test this: > https://github.com/openjdk/jdk/blob/master/test/jdk/java/foreign/TestNulls.java > But it is only checking if an NPE is thrown, and not checking for a message, > since

Re: RFR: 8262351: Extra '0' in java.util.Formatter for '%012a' conversion with a sign character [v2]

2021-03-10 Thread Brent Christian
On Wed, 10 Mar 2021 02:31:28 GMT, Ian Graves wrote: >> This fixes a zero-adding issue observed in the hex float conversion. > > Ian Graves has updated the pull request incrementally with one additional > commit since the last revision: > > Updating Formatter copyright date Marked as

Re: RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Roger Riggs
On Wed, 10 Mar 2021 15:33:43 GMT, Claes Redestad wrote: > Use requireNonNull instead. Well spotted. - Marked as reviewed by rriggs (Reviewer). PR: https://git.openjdk.java.net/jdk/pull/2914

Re: RFR: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Jorn Vernee
On Wed, 10 Mar 2021 16:04:22 GMT, Roger Riggs wrote: >> Use requireNonNull instead. > > Well spotted. Nice catch! We have a test that is supposed to test this: https://github.com/openjdk/jdk/blob/master/test/jdk/java/foreign/TestNulls.java But it is only checking if an NPE is thrown, and not

Re: RFR: 8262351: Extra '0' in java.util.Formatter for '%012a' conversion with a sign character [v2]

2021-03-10 Thread Naoto Sato
On Wed, 10 Mar 2021 02:31:28 GMT, Ian Graves wrote: >> This fixes a zero-adding issue observed in the hex float conversion. > > Ian Graves has updated the pull request incrementally with one additional > commit since the last revision: > > Updating Formatter copyright date Looks good to me.

Integrated: 8263333: Improve links from core reflection to JLS and JVMS

2021-03-10 Thread Joe Darcy
On Wed, 10 Mar 2021 06:19:27 GMT, Joe Darcy wrote: > The javadoc of various methods in core reflection would be improved by links > into the JLS. This pull request has now been integrated. Changeset: acda8129 Author:Joe Darcy URL: https://git.openjdk.java.net/jdk/commit/acda8129

Integrated: 8263380: Unintended use of Objects.nonNull in VarHandles

2021-03-10 Thread Claes Redestad
On Wed, 10 Mar 2021 15:33:43 GMT, Claes Redestad wrote: > Use requireNonNull instead. This pull request has now been integrated. Changeset: 7e52a6e8 Author:Claes Redestad URL: https://git.openjdk.java.net/jdk/commit/7e52a6e8 Stats: 14 lines in 1 file changed: 0 ins; 0 del; 14

Re: RFR: 8263333: Improve links from core reflection to JLS and JVMS

2021-03-10 Thread Joel Borggrén-Franck
On Wed, 10 Mar 2021 06:19:27 GMT, Joe Darcy wrote: > The javadoc of various methods in core reflection would be improved by links > into the JLS. Marked as reviewed by jfranck (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/2906

Integrated: 8262351: Extra '0' in java.util.Formatter for '%012a' conversion with a sign character

2021-03-10 Thread Ian Graves
On Mon, 8 Mar 2021 21:25:32 GMT, Ian Graves wrote: > This fixes a zero-adding issue observed in the hex float conversion. This pull request has now been integrated. Changeset: 6971c23a Author:Ian Graves Committer: Brent Christian URL:

Re: RFR: 8263105: security-libs doclint cleanup [v3]

2021-03-10 Thread Bradford Wetmore
On Wed, 10 Mar 2021 14:53:53 GMT, Roger Riggs wrote: >> Bradford Wetmore has updated the pull request incrementally with one >> additional commit since the last revision: >> >> More Codereview Comments > > src/java.base/share/classes/java/security/AllPermission.java line 165: > >> 163: >>

Re: RFR: 8263105: security-libs doclint cleanup [v3]

2021-03-10 Thread Bradford Wetmore
On Wed, 10 Mar 2021 19:02:40 GMT, Sean Mullan wrote: >> Bradford Wetmore has updated the pull request incrementally with one >> additional commit since the last revision: >> >> More Codereview Comments > > src/java.base/share/classes/java/security/PrivilegedActionException.java line > 101:

Re: RFR: 8263105: security-libs doclint cleanup [v2]

2021-03-10 Thread Bradford Wetmore
On Wed, 10 Mar 2021 15:10:35 GMT, Roger Riggs wrote: >> Bradford Wetmore has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Codereview Comment > > src/java.base/share/classes/javax/crypto/SealedObject.java line 425: > >> 423: *

Re: RFR: 8263105: security-libs doclint cleanup [v4]

2021-03-10 Thread Bradford Wetmore
On Mon, 8 Mar 2021 19:50:06 GMT, Bradford Wetmore wrote: >> src/java.base/share/classes/java/security/BasicPermission.java line 497: >> >>> 495: /** >>> 496: * @serialData Default fields. >>> 497: */ >> >> FWIW, this doc comment will be ignored, because it will be superseded by

RFR: 8251942: PrintStream specification is not clear which flush method is automatically invoked

2021-03-10 Thread Brian Burkhalter
Please review this minor change to the specification of `java.io.PrintStream`. The longstanding behavior for flushing is to invoke the `flush()` method of the underlying `OutputStream` rather than its override but this was not made explicit in the specification. - Commit messages:

New candidate JEP: 400: UTF-8 by Default

2021-03-10 Thread mark . reinhold
https://openjdk.java.net/jeps/400 Summary: Use UTF-8 as the JDK's default charset, so that APIs that depend on the default charset behave consistently across all platforms and independently of the user’s locale and configuration. - Mark

Integrated: 8263105: security-libs doclint cleanup

2021-03-10 Thread Bradford Wetmore
On Sat, 6 Mar 2021 07:31:09 GMT, Bradford Wetmore wrote: > Fix various things pointed out by the most recent doclint run in the > security-libs area. > > This is docs only: I will be checking doccheck/doclint, and will be running > tier1/tier2 tests. Minor spot checks on generated files.

Re: New candidate JEP: 400: UTF-8 by Default

2021-03-10 Thread Bernd Eckenfels
I like it. The only thing which I feel is missing would be an official API to get the operating environments default encoding (essentially to get the value used if COMPAT would have been specified). For example, in our server application, we do have some code which is specified as using

Re: RFR: 8263105: security-libs doclint cleanup [v4]

2021-03-10 Thread Bradford Wetmore
> Fix various things pointed out by the most recent doclint run in the > security-libs area. > > This is docs only: I will be checking doccheck/doclint, and will be running > tier1/tier2 tests. Minor spot checks on generated files. Bradford Wetmore has updated the pull request incrementally

Re: New candidate JEP: 400: UTF-8 by Default

2021-03-10 Thread Remi Forax
- Mail original - > De: "Bernd Eckenfels" > À: "core-libs-dev" > Cc: "jdk-dev" > Envoyé: Jeudi 11 Mars 2021 02:12:49 > Objet: Re: New candidate JEP: 400: UTF-8 by Default > I like it. The only thing which I feel is missing would be an official API to > get the operating environments

Re: New candidate JEP: 400: UTF-8 by Default

2021-03-10 Thread Bernd Eckenfels
Hello, Thanks for the hint. The question is if this would return UTF-8 after the JEP is implemented or not (should probably be mentioned in the JEP). If it keeps returning the legacy/platform file encoding that would be a good API for my purpose (but sounds like that would be rather confusing