[PATCH v2 0/3] Add support for the S6E3HF2 panel on TM2e board

2017-04-17 Thread Hoegeun Kwon
Hi all, First, thanks for Andrzej review. The purpose of this patch is add support for s6e3hf2 AMOLED panel on the TM2e board. The panel has 1600x2560 resolution in 5.65" physical panel in the TM2e device. The s6e3hf2 panel(5.65") is simliar to the previous s6e3ha2 panel(5.7"), but resolution

[PATCH v2 0/5] replace hwmon_device_register for hwmon_device_register_with_info

2017-04-17 Thread Oscar Salvador
Hi! This patchseries replaces the deprecated hwmon_device_register function with the new one hwmon_device_register_with_info. It also does some cleanup. Here is the list of patches and what they do: 1/ Adds config structures for all sensors and their possible settings. This patch and the

[PATCH v2 3/5] nouveau_hwmon: Remove old code, add .write/.read operations

2017-04-17 Thread Oscar Salvador
This patch removes old code related to the old api and transforms the functions for the new api. It also adds the .write and .read operations. Since we don't want to support changing hwmon_temp_* values, this patch deletes all write-functions for these attributes too. ---

[PATCH v2 5/5] nouveau_hwmon: Change permissions to numeric

2017-04-17 Thread Oscar Salvador
This patch replaces the symbolic permissions with the numeric ones, and adds me to the authors too. --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nouveau_hwmon.c

Re: [PATCH 1/2] drm: Add DRM_CAP_PRIME_SCANOUT.

2017-04-17 Thread Michel Dänzer
On 17/04/17 02:05 PM, Christopher James Halse Rogers wrote: > On 10 April 2017 6:51:21 pm AEST, "Michel Dänzer" wrote: >> On 06/04/17 04:47 PM, Christopher James Halse Rogers wrote: >>> On Wed, 5 Apr 2017 at 20:14 Lucas Stach >>

[PATCH v2 4/5] nouveau_hwmon: Add support for auto_point attributes

2017-04-17 Thread Oscar Salvador
This patch creates a special group attributes for attrs like "*auto_point*". We check if we have support for them, and if we do, we gather them all in an attribute_group's structure which is the parameter regarding special groups of hwmon_device_register_with_info. ---

[PATCH v2 1/5] nouveau_hwmon: Add config for all sensors and their settings

2017-04-17 Thread Oscar Salvador
This is a preparation for the next patches. It just adds the sensors with their possible configurable settings and then fills the struct hwmon_channel_info with all this information. --- drivers/gpu/drm/nouveau/nouveau_hwmon.c | 72 + 1 file changed, 72

[PATCH v2 2/5] nouveau_hwmon: Add nouveau_hwmon_ops structure with .is_visible/.read_string

2017-04-17 Thread Oscar Salvador
This patch introduces the nouveau_hwmon_ops structure, sets up .is_visible and .read_string operations and adds all the functions for these operations. This is also a preparation for the next patches, where most of the work is being done. This code doesn't interacture with the old one. It's just

[PATCH v2 2/3] drm/panel: s6e3ha2: Add support for s6e3hf2 panel on TM2e board

2017-04-17 Thread Hoegeun Kwon
This patch supports TM2e panel and the panel has 1600x2560 resolution in 5.65" physical. This identify panel type with compatibility string, also invoke display mode that matches the type. So add the check code for s6e3ha2 compatibility and s6e3hf2 type and select the drm_display_mode of default

Re: [RfC PATCH] drm: fourcc byteorder: brings header file comments in line with reality.

2017-04-17 Thread Ilia Mirkin
On Tue, Apr 11, 2017 at 10:18 AM, Ilia Mirkin wrote: >> However, I totally agree with Alex that someone with a BE machine >> should review the whole stack before we could be confident with anything. > > Here's what I'm confident about: xf86-video-nouveau worked just fine >

[PATCH v2 1/3] dt-bindings: Add support for samsung s6e3hf2 panel

2017-04-17 Thread Hoegeun Kwon
The samsung s6e3hf2 panel is a 5.65" 1600x2560 AMOLED panel connected using MIPI-DSI interfaces. The s6e3hf2 is add to samsung,s6e3ha2.txt binding because it is a panel similar to the s6e3ha2. So add the compatible string and comments. Signed-off-by: Hoegeun Kwon ---

[PATCH v2 3/3] arm64: dts: exynos: Add support for s6e3hf2 panel device on TM2e board

2017-04-17 Thread Hoegeun Kwon
This patch add the panel device tree node for s6e3hf2 display controller to TM2e dts. Signed-off-by: Hoegeun Kwon --- arch/arm64/boot/dts/exynos/exynos5433-tm2e.dts | 12 1 file changed, 12 insertions(+) diff --git

[Bug 100695] Texture artifacts in Deus Ex: Mankind Divided

2017-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100695 --- Comment #1 from Michel Dänzer --- Could be a duplicate of bug 100681. -- You are receiving this mail because: You are the assignee for the bug.___ dri-devel mailing list

[PATCH] drm/ttm: cleanup unuse ret value

2017-04-17 Thread Huang Rui
The ret must be 0 here, otherwise, the function will return after init_mem_type. Signed-off-by: Huang Rui --- drivers/gpu/drm/ttm/ttm_bo.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c index 9ee4ff4..5dcb4e1

Re: [PATCH 1/7] sync_file: get rid of internal reference count.

2017-04-17 Thread Sumit Semwal
On 17 April 2017 at 18:43, Gustavo Padovan wrote: > 2017-04-13 Dave Airlie : > >> From: Dave Airlie >> >> sync_file uses the reference count of the file, the internal >> kref was never getting moved past 1. >> >> We can reintroduce this

Re: [PATCH libdrm] Header: Add rotation property fields

2017-04-17 Thread Sumit Semwal
Hi Robert, On 13 April 2017 at 21:40, Robert Foss wrote: > From: Sean Paul > > From drm_crtc.h, for use with the plane "rotation" property. > > Signed-off-by: Sean Paul > Signed-off-by: Robert Foss

[Bug 100681] F1 2015 glitches (letters mainly)

2017-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100681 --- Comment #3 from Andy Furniss --- Possibly 300023 https://bugs.llvm.org/show_bug.cgi?id=32666 -- You are receiving this mail because: You are the assignee for the bug.___

Re: [PATCH] drm/vc4: Fix refcounting of runtime PM get if it errors out.

2017-04-17 Thread Sean Paul
On Mon, Apr 17, 2017 at 09:26:03AM -0700, Eric Anholt wrote: > We were returning without decrementing if the error happened, meaning > that at the next submit we wouldn't try to bring up the power domain. > > Signed-off-by: Eric Anholt This change looks good to me. It seems a

[Bug 100593] corruption in total war warhammer when using mesa 17.1 - git

2017-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100593 --- Comment #8 from Gašper Sedej --- Hi. My "shader color corruptions" bug was solved by "ppa-purge" and then again adding repository & updating. I was not using oibaf-ppa but padoka-ppa

Re: [PATCH 1/7] sync_file: get rid of internal reference count.

2017-04-17 Thread Gustavo Padovan
2017-04-13 Dave Airlie : > From: Dave Airlie > > sync_file uses the reference count of the file, the internal > kref was never getting moved past 1. > > We can reintroduce this if we decide we need it later. > > [airlied: fix buildbot warnings] > >

Re: [PATCH] drm/ttm: cleanup unuse ret value

2017-04-17 Thread Alex Deucher
On Mon, Apr 17, 2017 at 3:38 AM, Huang Rui wrote: > The ret must be 0 here, otherwise, the function will return after > init_mem_type. > > Signed-off-by: Huang Rui I think you can drop the initial assignment of ret as well. Either way: Reviewed-by: Alex

[PATCH] drm/vc4: Fix refcounting of runtime PM get if it errors out.

2017-04-17 Thread Eric Anholt
We were returning without decrementing if the error happened, meaning that at the next submit we wouldn't try to bring up the power domain. Signed-off-by: Eric Anholt --- I stumbled across this error when testing my CMA patch with a very low (64MB) CMA area -- we would oops on

Re: [PATCH 0/6] drm: msm: A5XX zap shader

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > Hey Rob - > > Here is the stack of stuff to add the zap shader for msm-next. I left > the code broken out as the first two changes are merged into the device > specific tree and the third one has been seen before so this should > hopefully cut

Re: [PATCH 2/6] drm/msm: gpu: Use the zap shader on 5XX if we can

2017-04-17 Thread Bjorn Andersson
On Mon 17 Apr 14:51 PDT 2017, Jordan Crouse wrote: > On Mon, Apr 17, 2017 at 12:58:07PM -0700, Bjorn Andersson wrote: > > On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > > > diff --git a/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > > > b/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > > > index

[PATCH] Make DMABUF a menuconfig to ease disabling it all

2017-04-17 Thread Vincent Legoll
No need to get into the submenu to disable all DMABUF-related config entries Make the selecters also select the new DMABUF menuconfig Signed-off-by: Vincent Legoll --- drivers/dma-buf/Kconfig | 7 --- drivers/gpu/drm/Kconfig | 1 +

Re: [PATCH 1/6] drm/msm: Add a quick and dirty PIL loader

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > diff --git a/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > b/drivers/gpu/drm/msm/adreno/a5xx_gpu.c [..] > +static int _pil_tz_load_image(struct platform_device *pdev) > +{ You should be able to replace this with a call into

Re: [PATCH v6 2/3] v4l: Add 10/16-bits per channel YUV pixel formats

2017-04-17 Thread Mauro Carvalho Chehab
Em Sun, 5 Mar 2017 18:00:32 +0800 Randy Li escreveu: > The formats added by this patch are: > V4L2_PIX_FMT_P010 > V4L2_PIX_FMT_P010M > V4L2_PIX_FMT_P016 > V4L2_PIX_FMT_P016M > Currently, none of driver uses those format. > > Also a variant of

Re: [PATCH 5/6] drm/msm: Move zap shader firmware name to the device table

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > The zap shader firmware name is not platform specific. Move it > to the device table instead. > > Signed-off-by: Jordan Crouse This looks good, but it should be squashed with the previous commits. Regards, Bjorn >

Re: [PATCH 3/6] drm/msm: Improve the zap shader

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > Simply the code use snprintf correctly and make sure that we memset > the rest of the segment if the memory size in the ELF file is larger > than the file size. > > Signed-off-by: Jordan Crouse Please squash this with

Re: [PATCH 2/6] drm/msm: gpu: Use the zap shader on 5XX if we can

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > diff --git a/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > b/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > index 6c55d24..0e2b00a 100644 > --- a/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > +++ b/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > @@ -470,6 +470,55 @@

Re: [PATCH 6/6] drm/msm: Document the zap-shader subnode for the GPU

2017-04-17 Thread Bjorn Andersson
On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > The 'zap-shader' subnode is used to define a phandle for the > PIL memory region that is required to load GPU secure firwmare images > (known as the "zap shader"). > > Signed-off-by: Jordan Crouse Acked-by: Bjorn

Re: [GIT PULL] exynos-drm-next

2017-04-17 Thread Inki Dae
2017년 04월 18일 11:21에 Andi Shyti 이(가) 쓴 글: > Hi Inki, > >> Andi Shyti (2): >> arm64: dts: exynos: Enable ir-spi in the TM2 and TM2E boards >> arm64: dts: exynos: Add stmfts touchscreen node for TM2 and TM2E > > weren't these patches taken already by Krzysztof? They are > already in

Re: [PATCH v2 1/3] dt-bindings: Add support for samsung s6e3hf2 panel

2017-04-17 Thread Andrzej Hajda
On 17.04.2017 08:02, Hoegeun Kwon wrote: > The samsung s6e3hf2 panel is a 5.65" 1600x2560 AMOLED panel connected > using MIPI-DSI interfaces. > > The s6e3hf2 is add to samsung,s6e3ha2.txt binding because it is a > panel similar to the s6e3ha2. So add the compatible string and > comments. > >

Re: [RfC PATCH] drm: fourcc byteorder: brings header file comments in line with reality.

2017-04-17 Thread Michel Dänzer
On 17/04/17 03:43 PM, Ilia Mirkin wrote: > On Tue, Apr 11, 2017 at 10:18 AM, Ilia Mirkin wrote: >>> However, I totally agree with Alex that someone with a BE machine >>> should review the whole stack before we could be confident with anything. >> >> Here's what I'm confident

Re: [RfC PATCH] drm: fourcc byteorder: brings header file comments in line with reality.

2017-04-17 Thread Michel Dänzer
On 18/04/17 02:04 PM, Ilia Mirkin wrote: > On Mon, Apr 17, 2017 at 10:53 PM, Michel Dänzer wrote: >> On 17/04/17 03:43 PM, Ilia Mirkin wrote: >>> On Tue, Apr 11, 2017 at 10:18 AM, Ilia Mirkin wrote: > However, I totally agree with Alex that someone

[PATCH libdrm v2] Header: Add rotation property fields

2017-04-17 Thread Robert Foss
From: Sean Paul From drm_crtc.h, for use with the plane "rotation" property. Signed-off-by: Sean Paul Signed-off-by: Robert Foss Reviewed-by: Sumit Semwal --- Changes since v1: - Added r-b

Re: [PATCH v2 2/3] drm/panel: s6e3ha2: Add support for s6e3hf2 panel on TM2e board

2017-04-17 Thread Andrzej Hajda
On 17.04.2017 08:02, Hoegeun Kwon wrote: > This patch supports TM2e panel and the panel has 1600x2560 resolution > in 5.65" physical. > > This identify panel type with compatibility string, also invoke > display mode that matches the type. So add the check code for s6e3ha2 > compatibility and

[Bug 100681] F1 2015 glitches (letters mainly)

2017-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100681 --- Comment #4 from Michel Dänzer --- (In reply to Andy Furniss from comment #3) > Possibly 300023 > > https://bugs.llvm.org/show_bug.cgi?id=32666 Usually the quickest way to a solution in cases like this is to report the

[GIT PULL] exynos-drm-next

2017-04-17 Thread Inki Dae
Hi Dave, Some improvements, fixups and cleanups to Exynos DRM. Ps. this pull-reuqest includes a merge tag from Krzysztof Kozlowski who is a Exynos SoC maintainer, which includes dt patches because these should be merged together with below one, drm/exynos: dsi: Fix the parse_dt

Re: [GIT PULL] exynos-drm-next

2017-04-17 Thread Inki Dae
2017년 04월 18일 11:05에 Inki Dae 이(가) 쓴 글: > Hi Dave, > >Some improvements, fixups and cleanups to Exynos DRM. > >Ps. this pull-reuqest includes a merge tag from Krzysztof Kozlowski >who is a Exynos SoC maintainer, which includes dt patches because >these should be merged together

Re: [RfC PATCH] drm: fourcc byteorder: brings header file comments in line with reality.

2017-04-17 Thread Ilia Mirkin
On Mon, Apr 17, 2017 at 10:53 PM, Michel Dänzer wrote: > On 17/04/17 03:43 PM, Ilia Mirkin wrote: >> On Tue, Apr 11, 2017 at 10:18 AM, Ilia Mirkin wrote: However, I totally agree with Alex that someone with a BE machine should review the whole

Re: [PATCH 2/6] drm/msm: gpu: Use the zap shader on 5XX if we can

2017-04-17 Thread Jordan Crouse
On Mon, Apr 17, 2017 at 12:58:07PM -0700, Bjorn Andersson wrote: > On Wed 12 Apr 14:15 PDT 2017, Jordan Crouse wrote: > > diff --git a/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > > b/drivers/gpu/drm/msm/adreno/a5xx_gpu.c > > index 6c55d24..0e2b00a 100644 > > ---

Re: [PATCH v3] drm/exynos: mixer: document YCbCr magic numbers

2017-04-17 Thread Inki Dae
2017년 04월 16일 20:50에 Tobias Jakobi 이(가) 쓴 글: > Hello Inki, > > Inki Dae wrote: > >> Tobias, why did you post the patch set 1/2 and 2/2 before? >> If these patches can be applied independently - you found out later - then >> you need to clarify why you posted them separately. > > > after I

[Bug 100306] System randomly freezes or crashes to the login screen, glitches until rebooted

2017-04-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=100306 --- Comment #18 from MirceaKitsune --- Nope, still happens in glx as well. Switching away from egl rendering does not make the freezes go away. -- You are receiving this mail because: You are the assignee

Re: [PATCH] drm/vc4: Fix refcounting of runtime PM get if it errors out.

2017-04-17 Thread Eric Anholt
Sean Paul writes: > On Mon, Apr 17, 2017 at 09:26:03AM -0700, Eric Anholt wrote: >> We were returning without decrementing if the error happened, meaning >> that at the next submit we wouldn't try to bring up the power domain. >> >> Signed-off-by: Eric Anholt

[PATCH] drm/cma: Fix recent regression of mmap() in the MMU case.

2017-04-17 Thread Eric Anholt
The stub get_unmapped_area() function was actually getting called, so all of our mmap()s failed. Cc: Yannick Fertre Fixes: 97bf3a9aa60f ("drm/cma: Update DEFINE_DRM_GEM_CMA_FOPS to add get_unmapped_area") Signed-off-by: Eric Anholt ---

Re: [PATCH] drm/ttm: cleanup unuse ret value

2017-04-17 Thread Huang Rui
On Mon, Apr 17, 2017 at 11:42:18PM +0800, Alex Deucher wrote: > On Mon, Apr 17, 2017 at 3:38 AM, Huang Rui wrote: > > The ret must be 0 here, otherwise, the function will return after > init_mem_type. > > > > Signed-off-by: Huang Rui > > I think you can