Re: [Pharo-dev] /

2016-08-18 Thread Ben Coman
On Fri, Aug 19, 2016 at 5:09 AM, Esteban A. Maringolo wrote: > 2016-08-18 17:30 GMT-03:00 Stephan Eggermont : >> On 18/08/16 14:38, stepharo wrote: >>> >>> Hi >>> >>> In my projects I start to do the following: >>> >>> I create class method that returns an

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread Denis Kudriashov
2016-08-18 13:32 GMT+02:00 stepharo : > withExtension: aString > > "Returns a new file reference with a different file extension" Does this comment is really needed? I only see extra word "different". And rest is same as method name. IMHO we should rename method to

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread Denis Kudriashov
Hi. 2016-08-18 9:34 GMT+02:00 stepharo : > withExtension: aString > > "Returns a new file reference with a different file extension" > > > value: '/tmp/file.log' asFileReference > > > ^ self withPath: (self path withExtension: aString) > > > So let me know what

Re: [Pharo-dev] /

2016-08-18 Thread Esteban A. Maringolo
2016-08-18 17:30 GMT-03:00 Stephan Eggermont : > On 18/08/16 14:38, stepharo wrote: >> >> Hi >> >> In my projects I start to do the following: >> >> I create class method that returns an prototypical instance. > > > Nice. Excellent inititive. I'm not a native speaker, and does

Re: [Pharo-dev] /

2016-08-18 Thread Nicolai Hess
2016-08-18 22:45 GMT+02:00 Denis Kudriashov : > > 2016-08-18 19:50 GMT+02:00 stepharo : > >> Hi >> >> Why not use pragma in the way you propose for ? Why >> we need two? >> >> >> Apparently from the old discussion, people like to prompt and >> open the

Re: [Pharo-dev] /

2016-08-18 Thread Tudor Girba
Hi, I am happy to see the concept of an example method catching attention again. As explained before, the GTExample was already present in the Pharo image, but it was introduced more as a helper for testing GT extensions. Now, I just created an issue for removing GTExamples from the

Re: [Pharo-dev] /

2016-08-18 Thread Denis Kudriashov
2016-08-18 19:50 GMT+02:00 stepharo : > Hi > > Why not use pragma in the way you propose for ? Why we > need two? > > > Apparently from the old discussion, people like to prompt and > open the example > when this is something visual. This is ok for me. > Ok, let's distinguish

Re: [Pharo-dev] /

2016-08-18 Thread Stephan Eggermont
On 18/08/16 14:38, stepharo wrote: Hi In my projects I start to do the following: I create class method that returns an prototypical instance. Nice. Excellent inititive. I'm not a native speaker, and does not sound like the right name for this to me. That might be me being dutch. Native

Re: [Pharo-dev] /

2016-08-18 Thread stepharo
A little blog post to explain https://wordpress.com/post/pharoweekly.wordpress.com/1190 Stef

Re: [Pharo-dev] /

2016-08-18 Thread stepharo
Le 18/8/16 à 21:31, stepharo a écrit : Hi all I implemented the to behave as suggested by torsten and it is available in less than 5 min (I loved it). An example is JUST a class method returning an instance. examplar is JUST... :) CTGrid class >> grid22 "self grid22" |

Re: [Pharo-dev] /

2016-08-18 Thread stepharo
Hi all I implemented the to behave as suggested by torsten and it is available in less than 5 min (I loved it). An example is JUST a class method returning an instance. CTGrid class >> grid22 "self grid22" | grid1 | grid1 := self new: 2. grid1 atRow: 1 atColumn: 1 put:

Re: [Pharo-dev] /

2016-08-18 Thread stepharo
Hi Why not use pragma in the way you propose for ? Why we need two? Apparently from the old discussion, people like to prompt and open the example when this is something visual. This is ok for me. In my proposal we can get the best of both worlds. - instance to use in tests -

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread stepharo
As I already told you and the board, I will just leave if such a solution get pushed into Pharo. Hi, I like this problem very much. I think we are not leveraging the objects we have in the image. Tests can help, but they are way too disconnected from the code and they are not really useful

Re: [Pharo-dev] /

2016-08-18 Thread Esteban Lorenzano
example is meant to be something executable from the browser (and with a visible result) while “exemplar” will just provide a prototype. this is old discussion, sigh... Esteban > On 18 Aug 2016, at 16:25, Denis Kudriashov wrote: > > Hi > > Why not use pragma in the

Re: [Pharo-dev] /

2016-08-18 Thread Denis Kudriashov
Hi Why not use pragma in the way you propose for ? Why we need two? 2016-08-18 14:38 GMT+02:00 stepharo : > Hi > > In my projects I start to do the following: > > I create class method that returns an prototypical instance. > > I use such methods in my tests as fixture. > >

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread Tudor Girba
Hi, > On Aug 18, 2016, at 2:41 PM, stepharo wrote: > > Hi doru > > >> Hi, >> >> I like this problem very much. I think we are not leveraging the objects we >> have in the image. Tests can help, but they are way too disconnected from >> the code and they are not really

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread stepharo
Hi doru Hi, I like this problem very much. I think we are not leveraging the objects we have in the image. Tests can help, but they are way too disconnected from the code and they are not really useful for detailed questions. I am also happy that you are considering the use of pragmas for

[Pharo-dev] /

2016-08-18 Thread stepharo
Hi In my projects I start to do the following: I create class method that returns an prototypical instance. I use such methods in my tests as fixture. Then I would like to have nautilus presenting to me the with a little triangle and when I press on them I get an inspector on them. This

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread Tudor Girba
Hi, I like this problem very much. I think we are not leveraging the objects we have in the image. Tests can help, but they are way too disconnected from the code and they are not really useful for detailed questions. I am also happy that you are considering the use of pragmas for this

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread stepharo
Tx serge - I think that we should agree on the pragma or way to express it. May be we can do the same as in Python and use a comment instead of a pragma. I prefer a pragma because we can query them easily. So any idea instead of withExtension: aString "Returns a new file

[Pharo-dev] Abotu FileReference objects as autoevaluating ones

2016-08-18 Thread stepharo
about https://pharo.fogbugz.com/f/cases/18956/FileReference-printString-should-be-auto-evaluable 'tmp/foo.txt' asFileReference > File @ tmp/foo.txt and it would be much much better to get back 'tmp/foo.txt' asFileReference So that we can get { 'tmp/foo.txt' asFileReference } > {

Re: [Pharo-dev] Experience with FileSystem => proposal for improving user experience

2016-08-18 Thread stepharo
Proposal two: We could add withoutBasename withoutBasename ^ self parent I don't see a point of this method, why not just use #parent? This is a helper. parent is good for navigation now withoutBasename is good for manipulation of parts. It took me a

Re: [Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread Serge Stinckwich
On Thu, Aug 18, 2016 at 9:34 AM, stepharo wrote: > Hi guys > > I'm fed up to get methods without comments and without little examples. In +1 ! We can setup a small group of people interested to build examples at ESUG. > FileSystem, I wrote most of the comments and I tried to

Re: [Pharo-dev] Experience with FileSystem => proposal for improving user experience

2016-08-18 Thread Peter Uhnak
On Thu, Aug 18, 2016 at 09:35:28AM +0200, stepharo wrote: Just so you don't misunderstand… I am not opposing those changes, I am just asking. > > > > Proposal one: > > > > We could add withoutExtension > > > > withoutExtension > > > >^ (self parent /

[Pharo-dev] Email bankruptcy: Can not keep up with mails

2016-08-18 Thread Marcus Denker
Hi, Over the summer with holidays email accumulated… I started to get them down but there a re now still >300 unread Pharo mails left. I decided I will just delete them… if you expected an answer/input from me —> send me a private mail. Marcus

Re: [Pharo-dev] Experience with FileSystem => proposal for improving user experience

2016-08-18 Thread stepharo
Le 17/8/16 à 22:11, Peter Uhnák a écrit : On Wed, Aug 17, 2016 at 9:44 PM, stepharo > wrote: Hi I have a file /Users/ducasse/PharoMooc/Subtitles/W1/C019SD-W1-sous-titres-EN/EN_C019SD-W1-S1.srt and I would like to generate a

[Pharo-dev] About PythonDocTest for Pharo

2016-08-18 Thread stepharo
Hi guys I'm fed up to get methods without comments and without little examples. In FileSystem, I wrote most of the comments and I tried to add an obvious example: basenameWithIndicator "Returns the basename with the indicator appended, i.e. /foo/gloops.taz basenameWithIndicator is

[Pharo-dev] [Issue tracker] push on old issues needed

2016-08-18 Thread Marcus Denker
Hi, The issue tracker is accumulating issues fast… lots of them a half-finished, yet saw no action for quite some time… Keep in mind that if *you* will not look at an issue you where involved in (or even created), chances are that *nobody* will look at it… it is your job to push it forward.

[Pharo-dev] [pharo-project/pharo-core] 5b4669: 60187

2016-08-18 Thread GitHub
Branch: refs/heads/6.0 Home: https://github.com/pharo-project/pharo-core Commit: 5b46698f658ee35055ac458d437d32035630c99a https://github.com/pharo-project/pharo-core/commit/5b46698f658ee35055ac458d437d32035630c99a Author: Jenkins Build Server Date: