Re: [qubes-users] Upgrade from RC3 to final release

2018-04-04 Thread kototamo
> Sure, if it still doesn't work after you do the above. :) :) I managed to get the updates from testing but still see `fc25` instead of `fc26` in the repo file. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group

Re: [qubes-users] Upgrade from RC3 to final release

2018-04-04 Thread kototamo
Thanks for the link. I see I have still some references to fc25 in the repo file. How do I upgrade to fc26? Could you paste the content of your repo file? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop

[qubes-users] Upgrade from RC3 to final release

2018-04-03 Thread kototamo
I used RC3 and always update from stable repo, never from testing. Do I have now the good repos in yum? I think I have outdated yum repos and cannot update to final. Can somebody paste the content of its /etc/yum.repos.d/qubes-dom0.repo file? How am I supposed to ugprade to the final

[qubes-users] Do allowing USB Keyboard expose to badusb attacks?

2018-01-24 Thread kototamo
If a USB keyboard is allowed with /etc/qubes-rpc/policy/qubes.InputKeyboard, does it increase the risk for badusb kind of attacks? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it,

[qubes-users] Q4RC3: fedora 26 dvm not displayed as disposable

2018-01-10 Thread kototamo
After following the instructions for using the fedora 26 template, it does not show in the app menu as disposable, only as "Domain: fedora-26-dvm". I executed: sudo qubes-dom0-update qubes-template-fedora-26 qvm-create -l red -t fedora-26 fedora-26-dvm qvm-prefs fedora-26-dvm

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2018-01-07 Thread kototamo
Thanks everyone for the replies. I finally opted for RC3 and after fixing the iso with a live fedora and livecd-tools it went almost almost without problems. The only problem was that the keyboard layout chosen during the installation was not taken in account for promting the encryption

[qubes-users] Re: Q4: Enabling updates for templates restored from Qubes 3

2018-01-05 Thread kototamo
Maybe it is necessary to $ apt-get install qubes-core-agent in the VM after update, not sure. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Q4: Enabling updates for templates restored from Qubes 3

2018-01-05 Thread kototamo
I just spent a good time getting my backuped templates from Qubes 3 to work in Qubes 4 RC3. I'm posting here what I did (roughly) to get it work, in the hope it can help somebody. After running qvm-backup-restore, starts a terminal for your VM: $ qvm-run mytemplate gnome-terminal In the VM,

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread kototamo
Thank you for your reply. Could you explain to me why using EFI would solve the problem of the X server not starting? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an

Re: [qubes-users] New HCL Entry: Lenovo ThinkPad T470 (20HDCTO1WW)

2017-12-15 Thread kototamo
Hello everyone, I tried to install Qubes 3.2 on a T470s without success. I have the version with the Intel graphics. I did everything in Legacy Mode (no EFI). It does boot but the X server cannot start. Text installation did not work. Stephan Marwedel says in this thread he managed to install

[qubes-users] Using software installed in /rw/usrconfig/bin

2017-09-29 Thread kototamo
After adding some private debian repositories for erlang and elixir in the VM template and installing them, I noticed that they get installed in /rw/usrlocal/bin and /rw/usrlocal/lib. - What are these directories for? - How can I use the software in the app VM? -- You received this message

Re: [qubes-users] Massive performance improvement after disabling power management in the BIOS

2016-12-01 Thread kototamo
> Hi, might I ask what manufacturer/model your laptop is? Lenovo X240. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Massive performance improvement after disabling power management in the BIOS

2016-11-17 Thread kototamo
Hello community, I was wondering why one of my program was taking ~15 seconds to compile when my colleague compiled it within ~3 seconds on his system. I know there are a performance price to pay for the virtualisation but nonetheless. I was super annoyed and I vaguely thinking about switching

[qubes-users] Re: Google Maps producing a very high CPU usage

2016-10-13 Thread kototamo
I found a solution by disabling WebGL. There were errors in the console indicating that the operation executed by the page are slow. It is possible to set webgl.disable to true in about:config. Now it's acceptably slow :) -- You received this message because you are subscribed to the Google

Re: [qubes-users] Start VM automatically on boot not working

2016-09-11 Thread kototamo
Hum thank you. I didn't do that but somehow it works now. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to qubes-users+unsubscr...@googlegroups.com. To post to

Re: [qubes-users] Start VM automatically on boot not working

2016-09-09 Thread kototamo
and further: libvirt.libvirtError: Requested operation is not valid: Domain is already running. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an email to

[qubes-users] Start VM automatically on boot not working

2016-09-09 Thread kototamo
Hello, After cloning sys-firewall into sys-vpn-firewall with qvm-clone in dom0, and selection "Start VM automatically on boot not working " in the preferences of sys-vpn-firewall, the VM does not start automatically after reboot/ new starts. It does however start when a VM using it as a NetVM

Re: [qubes-users] seafile applet integration with the panel is not working

2016-09-04 Thread kototamo
Thanks for listing these bugs. It is probably something else: the icon neither appear/disappear nor is being transparent. It is just not being shown. There is something specific to the seafile-applet: it is an application that can be minimized in the system tray, not only an "applet". Maybe

[qubes-users] seafile applet integration with the panel is not working

2016-09-03 Thread kototamo
Hello, The seafile-applet (a kind of open-souce dropbox) is not being displayed in the xfce panel when started. Is there something specific to check or fix to get it working? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from

Re: [qubes-users] No DNS with ProxyVM + OpenVPN

2016-08-16 Thread kototamo
> To test this theory, you could put a 7sec delay in qubes-vpn-handler.sh > right before the line 'iptables -t nat -F PR-QBS'. Then the right IPs > should appear in PR-QBS. It did work. Thank you again! I wonder what is changing the NAT rules. I only see one 'up' directive in the openvpn

Re: [qubes-users] No DNS with ProxyVM + OpenVPN

2016-08-15 Thread kototamo
Thank you very much for your help. The DNS are transmitted but the rules in the firewall seems to be missing: Chain PR-QBS (1 references) pkts bytes target prot opt in out source destination 0 0 DNAT udp -- anyany anywhere

[qubes-users] No DNS with ProxyVM + OpenVPN

2016-08-15 Thread kototamo
Hi, I set up a proxyVM with openvpn following the instructions from https://www.qubes-os.org/doc/vpn/. I cannot do DNS query over the VPN, for example this command executed from a VM connected to the Proxy: [user@fedora-23-dvm ~]$ dig www.google.com ; <<>> DiG

Re: [qubes-users] VPN with PPTP failing

2016-08-14 Thread kototamo
> modprobe ip_conntrack_pptp > modprobe ip_nat_pptp > iptables -I FORWARD -p 47 -s X.X.X.X -J ACCEPT > What setup do I need for a ProxyVM? -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving

[qubes-users] VPN with PPTP failing

2016-08-13 Thread kototamo
Hi, I'm trying to setup a VPN connection with PPTP from sys-net (first tried with the ProxyVM but it also didn't work) without success. Any help is welcome, here below the logs. I also tried $ sudo modprobe nf_conntrack_pptp without success. I'm using the fedora template. Plugin

[qubes-users] How does "Allow DNS queries" work?

2016-08-08 Thread kototamo
Hello, I would like to know how the "Allow DNS queries" in the firewall settings works. Specially, are all DNS queries allowed or only the one targetting the DNS of the sys-net VM? If DNS queries on arbitrary servers are allowed, wouldn't it make it easy for an attacker to exfiltrate

Re: [qubes-users] Qubes R3.2 Failed to Load Kernel Modules

2016-08-07 Thread kototamo
I experience the same. It is slightly disturbing since this one of the first message appearing in the console with big red letters: FAILED. :) -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving

[qubes-users] Re: i3wm tiling window manager - is qubes-manager supposed to work?

2016-08-06 Thread kototamo
I had the same problem but after killing the qube-manager that was in the background and restarting it it worked. Also after reboot it works. Hope this helps. -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and

[qubes-users] USB keyboard with trackpad and trackpoint recognized as mouse

2016-08-06 Thread kototamo
Hi, I have a USB keyboard with an integrated trackpad and trackpoint. When connecting it Qubes if sys-usb can execute Qubes.InputMouse. How can I get it recognized as a keyboard + mouse? thanks in advance. -- You received this message because you are subscribed to the Google Groups

[qubes-users] Device attached failed with USB3

2016-08-05 Thread kototamo
Hi, When attaching a USB3 hard-drive to the untrusted VM I get the following error: dom0$ qvm-usb -a untrusted sys-usb:4-1 ERROR: Device attach failed: sh: printf: I/O error untrusted$ dmesg <...> [ 7482.281057] vhci_hcd: connection closed [ 7482.281166] vhci_hcd: stop threads [ 7482.281197]

[qubes-users] Re: Poor performance when reading external DVD

2016-08-05 Thread kototamo
> In VLC try to change output mode to x11, that dropped my cpu use by 60% to > 20%. It did help. Thank you so much! -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from it, send an

[qubes-users] Re: Poor performance when reading external DVD

2016-08-05 Thread kototamo
When testing with Xine I got bad performance and this error message: "The amount of dropped frame is too high, your system might be slow, not properly optimized or just too loaded". I have an integrated intel card for video, how can I check it is properly configured? -- You received this

[qubes-users] Re: Poor performance when reading external DVD

2016-08-05 Thread kototamo
It seems to be related to VLC because mplayer works nicely! Very good news. Here the command for history: $ mplayer -zoom -fs -vo x11 dvd:// -dvd-device /dev/sr0 -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group

[qubes-users] Re: External USB DVD fails to attach to the VM

2016-08-05 Thread kototamo
I found the solution by reading this: https://www.qubes-os.org/doc/usb/ and not this https://www.qubes-os.org/doc/assigning-devices/ -- You received this message because you are subscribed to the Google Groups "qubes-users" group. To unsubscribe from this group and stop receiving emails from

[qubes-users] External USB DVD fails to attach to the VM

2016-08-05 Thread kototamo
Hi, I'm using an optical DVD reader/burner and attached it to one of the VM: dom0$ qvm-block -l sys-usb:sr0 Slim_USB_Burner (0782852) 6GiB (attached to 'my-new-vm' as 'xvdi') It fails to show up in the VM: [user@my-new-vm ~]$ ls -alh /dev/xvdi ls: cannot access /dev/xvdi: No such file or

[qubes-users] [3.2rc2] Default VMs failed to get created after installation

2016-07-31 Thread kototamo
Hi, I gave up on installing on a USB stick and managed to get my hands on a second disk and installed Qubes on it. Everything went fine but after the first boot when configuring the VMs the following error appeared "A VM with the name 'sys-firewall' does not exist in the system". Can I

Re: [qubes-users] [3.2rc2] Cannot execute Qubes configuration after installing

2016-07-31 Thread kototamo
Yes it was the same before. The option was unchecked. I would have expect the option to be enabled if the message is "blabla disabled" and the checked option off. Anyway, not sure how to investigate further from here. -- You received this message because you are subscribed to the Google

Re: [qubes-users] [3.2rc2] Cannot execute Qubes configuration after installing

2016-07-31 Thread kototamo
I retried, booting with a USB keyboard plugged in, without success. Even if the keyboard works, I cannot check the option "USB Qube configuration disabled". I have the option 'default system qubes', 'default applications VMs' and 'create Whonix' checked. -- You received this message because