[ovirt-users] Debian - based OS and SSO

2016-07-28 Thread Tadas
Hello, still having issues with ovirt SSO and Debian OS. Other OSes (Windows/Fedora 24) works just fine. Some information: OS: Debian 8.5 (jessie) I've followed manual on https://www.ovirt.org/documentation/how-to/gues t-agent/install-the-guest-agent-in-debian/ and installed ovirt-agent. I can get

Re: [ovirt-users] Debian - based OS and SSO

2016-07-28 Thread Tadas
Subject: Re: [ovirt-users] Debian - based OS and SSO On Jul 28, 2016, at 3:11 PM, Vinzenz Feenstra <vfeen...@redhat.com> wrote: On Jul 28, 2016, at 11:53 AM, Tadas <ta...@ring.lt> wrote: Hello, still having issues with ovirt SSO and Debian OS. Other OSes (Windo

Re: [ovirt-users] Debian - based OS and SSO

2016-07-29 Thread Tadas
session include passwd Now it seems, that login works just fine. THank you for your help. On Fri, 2016-07-29 at 14:41 +0300, Tadas wrote: > Okay, now its different story. ovirt-agent finally passes through all > login steps: > > Dummy-1::INFO::2016-07-29 > 14:37:38,088::

Re: [ovirt-users] Debian - based OS and SSO

2016-07-29 Thread Tadas
credential check. If I comment out credential validation segment in CredServer.py, authentication seems to pass, gdm3 tries to load user profile and then crashes: http://paste.ubuntu.com/21391057/ On Fri, 2016-07-29 at 13:35 +0300, Tadas wrote: > There's another interesting error thrown out f

Re: [ovirt-users] Debian - based OS and SSO

2016-07-29 Thread Tadas
Yes, it seems that authentication does not work in any of debian releases. Oh well. On Fri, 2016-07-29 at 09:37 +0200, Vinzenz Feenstra wrote: > > > On Jul 28, 2016, at 4:11 PM, Tadas <ta...@ring.lt> wrote: > > > > Thank you for your reply. > > Strange, but i d

Re: [ovirt-users] Debian - based OS and SSO

2016-07-29 Thread Tadas
has no attribute 'SO_PASSCRED' On Fri, 2016-07-29 at 13:13 +0300, Tadas wrote: > Yes, it seems that authentication does not work in any of debian > releases. Oh well. > On Fri, 2016-07-29 at 09:37 +0200, Vinzenz Feenstra wrote: > > > > > > > > > > On Jul 28,

Re: [ovirt-users] Debian - based OS and SSO

2016-07-29 Thread Tadas
::CredServer::277::root::Credentials channel was closed. Though gdm3 fails to load session with following error: http://paste.ubuntu.com/21392715/ On Fri, 2016-07-29 at 13:25 +0200, Vinzenz Feenstra wrote: > > > > On Jul 29, 2016, at 12:35 PM, Tadas <ta...@ring.lt> wrote: > &

Re: [ovirt-users] Fedora 24 SSO

2016-07-26 Thread Tadas
Thank you. This did the trickOn Tue, 2016-07-26 at 12:26 +0200, Vinzenz Feenstra wrote: > > > On Jul 26, 2016, at 11:39 AM, Vinzenz Feenstra <vfeen...@redhat.com > > > wrote: > > > > > On Jul 22, 2016, at 7:38 AM, Tadas <ta...@ring.lt> wrote: > >

Re: [ovirt-users] ovirt-Guest-agent CPU usage

2016-08-11 Thread Tadas
ed to have socket open for read or write on hypervisor side. If not - ovirt agent will consume one cpu thread. And this happens only in Windows VM. On Thu, 2016-08-11 at 14:01 +0200, Vinzenz Feenstra wrote: > > > > On Aug 11, 2016, at 12:21 PM, Tadas <ta...@ring.lt> wrote: >

Re: [ovirt-users] ovirt-Guest-agent CPU usage

2016-08-11 Thread Tadas
To: ta...@ring.lt Cc: users@ovirt.org Subject: Re: [ovirt-users] ovirt-Guest-agent CPU usage On Aug 11, 2016, at 2:20 PM, Tadas <ta...@ring.lt> wrote: Sorry, managed to send corrupted message. I do not think there's problems with virtio console drivers. I've installed ovirt guest tools is

Re: [ovirt-users] ovirt-Guest-agent CPU usage

2016-08-11 Thread Tadas
visor side. If not - ovirt agent will consume one cpu thread. And this happens only in Windows VM. On Thu, 2016-08-11 at 15:13 +0300, Tadas wrote: > "socat pathtosocketfile  -" > This gives me all information about VM from ovirtagent. But as soon > as > i close reading soc

Re: [ovirt-users] ovirt-Guest-agent CPU usage

2016-08-11 Thread Tadas
I will try to compile it again. I've installed via ovirt commandline "OVirtGuestService.exe -install". Maybe i've managed to put wrong daemon. Will try this again. Thank you. -Original Message- From: Vinzenz Feenstra Sent: Thursday, August 11, 2016 4:24 PM To: Tadas

Re: [ovirt-users] ovirt-Guest-agent CPU usage

2016-08-11 Thread Tadas
Thank you again. Recompiling to latest ovirt agent solved issue. -Original Message- From: Vinzenz Feenstra Sent: Thursday, August 11, 2016 4:24 PM To: Tadas Cc: users@ovirt.org Subject: Re: [ovirt-users] ovirt-Guest-agent CPU usage On Aug 11, 2016, at 3:08 PM, Tadas <ta...@ring

Re: [ovirt-users] Multipath iSCSI with several IPs

2016-08-04 Thread Tadas
Multipath is more a SAN thing, - not a tcp/ip. You should use something like LACP group on two (or more) of your network interfaces. Also you will have to configure your switch accordingly. You will not have to worry about second ip. LACP bonded interface will use one IP, but will fail-over to

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
SSO part as simple as emitting correctly formed json to spice socket, - as I’ve mentioned before, this works fine with windows guests. Problem is only with linux guests. As for undocummented API, yes, – you are right, documentation should help alot. It takes time to reverse engineer code. But

[ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
Hello, i'm struggling to get oVirt SSO working on Linux guest VM. I can confirm, that SSO is fully functional on Windows guest (please note it's not a full oVirt installation - I'm just testing oVirt guest agent on virtual machines running on plain KVM hypervisor). Steps I've made: got oVirt

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-15 Thread Tadas
Thank you for reply. you =hould just add ovirtcred and not remove all the other options, without =he other options you’re not able to login There are other options, i’ve just changed the folowing parameter: PluginsLogin=ovirtcred should i use somekind of plugin list and add the classic

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
After moving to gdm, I've managed to solve the timeout issue. Now i bumped into another one: oVirt agent seem to emit credentials without error: Dummy-1::DEBUG::2016-07-18 09:29:53,293::OVirtAgentLogic::304::root::User log-in (credentials = '\x00\x00\x00\x04test\x00')

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
18 14:11:28 desktop64 cred-debug: send() failed Jul 18 14:11:33 desktop64 cred-debug: recv() failedOn Mon, 2016-07-18 at 09:51 +0300, Tadas wrote: > After moving to gdm, I've managed to solve the timeout issue. Now i > bumped into another one: > oVirt agent seem to emit credentials with

Re: [ovirt-users] Debian linux and oVirt SSO

2016-07-18 Thread Tadas
ovirt agent stops on this line and code below it is not executed: https://github.com/oVirt/ovirt-guest-agent/blob/master/ovirt-guest-agen t/CredServer.py#L147 On Mon, 2016-07-18 at 14:12 +0300, Tadas wrote: > This is really interesting. > pam-ovirt-cred is randomly failing on one

[ovirt-users] Communicating with ovirt agent

2016-07-01 Thread Tadas
is there any documentation o oVirt guest agent commands? To be more precise: i need to pass commands to oVirt guest agent from hypervisor. Reading info works fine: socat /var/lib/libvirt/qemu/channel/target/domain-20- win7_32bit/com.redhat.serial.0 - {"applications": ["Python 2.7.12rc1", "SPICE

Re: [ovirt-users] Communicating with ovirt agent

2016-07-01 Thread Tadas
, 2016 2:53 PM To: ta...@ring.lt Cc: users@ovirt.org Subject: Re: [ovirt-users] Communicating with ovirt agent On Jul 1, 2016, at 12:05 PM, Tadas <ta...@ring.lt> =rote: is there any documentation o oVirt guest agent =ommands? To be more precise: i need to pass commands to =Virt guest

Re: [ovirt-users] Communicating with ovirt agent

2016-07-01 Thread Tadas
Thank you very much. Seems to work now. From: Vinzenz Feenstra Sent: Friday, July 01, 2016 5:37 PM To: Tadas Cc: users@ovirt.org Subject: Re: [ovirt-users] Communicating with ovirt agent On Jul 1, 2016, at 4:24 PM, Tadas <ta...@ring.lt> wrote: Thank you for reply! Im trying t

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
l 4, 2016 at 10:25 AM, Tadas <ta...@ring.lt> wrote: > > I'm developing a simple VDI solution for our university. And I find > > "windows-credprov" and "virt-agent" very useful to provide SSO from > > user dashboard to VM. > > > &g

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
Got everything working now. Thank you for your help. For any users, whom it may be useful, heres the code for external (SSO) logins from hypervisor. http://paste.ubuntu.com/18435531/ On Fri, 2016-07-01 at 13:53 +0200, Vinzenz Feenstra wrote: > > > On Jul 1, 2016, at 12:05 PM,

Re: [ovirt-users] Communicating with ovirt agent

2016-07-04 Thread Tadas
10:25 AM, Tadas <ta...@ring.lt> wrote: > > I'm developing a simple VDI solution for our university. And I find > > "windows-credprov" and "virt-agent" very useful to provide SSO from > > user dashboard to VM. > > > > But we already provid