Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-22 Thread calder
On Mon, Jun 22, 2020, 11:56 James H. H. Lampert wrote: > On 6/20/20 8:41 AM, Mark Thomas wrote: > > > 7.0.105 hasn't been released yet. You can use catalina.sh from 7.0 > > 103 or the latest version from source control. > > Where would I find "the latest version from source control"? >

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-22 Thread James H. H. Lampert
On 6/20/20 8:41 AM, Mark Thomas wrote: 7.0.105 hasn't been released yet. You can use catalina.sh from 7.0 103 or the latest version from source control. Where would I find "the latest version from source control"? -- JHHL -

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-20 Thread Mark Thomas
On June 19, 2020 10:49:54 PM UTC, "James H. H. Lampert" wrote: >On 6/19/20 3:20 PM, Mark Thomas wrote: >> https://bz.apache.org/bugzilla/show_bug.cgi?id=64501 > >Hmm. I'm now looking through the entire catalina.sh script in both >versions. (First, I looked through the startup.sh script; that

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-20 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 James, On 6/19/20 18:49, James H. H. Lampert wrote: > On 6/19/20 3:20 PM, Mark Thomas wrote: >> https://bz.apache.org/bugzilla/show_bug.cgi?id=64501 > > Hmm. I'm now looking through the entire catalina.sh script in both > versions. (First, I looked

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread James H. H. Lampert
On 6/19/20 3:20 PM, Mark Thomas wrote: https://bz.apache.org/bugzilla/show_bug.cgi?id=64501 Hmm. I'm now looking through the entire catalina.sh script in both versions. (First, I looked through the startup.sh script; that appears to be identical in both versions.) First thing I noticed was

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread Mark Thomas
On 19/06/2020 21:14, James H. H. Lampert wrote: > Ladies and Gentlemen: > > In preparation for updating a customer box, I installed Tomcat 7.0.104 > on our own AS/400 (64-bit Java 6 JVM). > > 7.0.93 works just fine on our box, but 7.0.104 seems to crash on > takeoff, producing no log files, just

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread James H. H. Lampert
On 6/19/20 2:27 PM, calder wrote: a) it's worth asking the obvious ... are the file permissions correct for the new TCp installation, i.e , such as read/write in "logs" subdir and execute permissions for the TC scripts? Unless something weird is going on with the apache-tomcat-7.0.104.zip

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread calder
On Fri, Jun 19, 2020, 15:33 James H. H. Lampert wrote: > On 6/19/20 1:26 PM, calder wrote: > > a) are both Tomcat instances installed on that same server? > > Yes > > > b) if yes, is the 7.0.93 instance running when you launch the 7.0.104 > > instance? > > No. > > We've done this procedure

Re: Strange crash-on-takeoff, Tomcat 7.0.104 (Trying again)

2020-06-19 Thread James H. H. Lampert
On 6/19/20 1:24 PM, Christopher Schultz wrote: My guess is that the system-property-setting part of catalina.sh (or some other script) is getting fouled-up. What script(s) are you running to start Tomcat? Remember, we're talking about IBM Midrange systems, not *nix. So bash is entirely

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread James H. H. Lampert
On 6/19/20 1:24 PM, Christopher Schultz wrote: My guess is that the system-property-setting part of catalina.sh (or some other script) is getting fouled-up. What script(s) are you running to start Tomcat? Remember, we're talking about IBM Midrange systems, not *nix. So bash is entirely

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread James H. H. Lampert
On 6/19/20 1:26 PM, calder wrote: a) are both Tomcat instances installed on that same server? Yes b) if yes, is the 7.0.93 instance running when you launch the 7.0.104 instance? No. We've done this procedure before: installing a new version, doing the setup in the new version, then

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread calder
On Fri, Jun 19, 2020, 15:15 James H. H. Lampert wrote: > Ladies and Gentlemen: > > In preparation for updating a customer box, I installed Tomcat 7.0.104 > on our own AS/400 (64-bit Java 6 JVM). > > 7.0.93 works just fine on our box, but 7.0.104 seems to crash on > takeoff, producing no log

Re: Strange crash-on-takeoff, Tomcat 7.0.104

2020-06-19 Thread Christopher Schultz
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 James, On 6/19/20 16:14, James H. H. Lampert wrote: > Ladies and Gentlemen: > > In preparation for updating a customer box, I installed Tomcat > 7.0.104 on our own AS/400 (64-bit Java 6 JVM). > > 7.0.93 works just fine on our box, but 7.0.104 seems