>>Dear list,
>>
>>I have spacewalk 2.4 installed on a CentOS 7 host, and manage CentOS 7
>>servers with it. Now I found that in /etc/yum.repos.d/ all configured
>>repositories point to Internet repos. Which is not really how it should
>>be, hosts should use the internal spacewalk repos. I assume this is due
>>to packages like centos-release* being installed. I am just taking over
>>this environment, so I am not 100% sure how all this came together.
>>
>>Nonetheless, I need to fix this. If I just delete the packages to which
>>the repo definitions belong to, I am left without any repositories (I
>>have checked - none point to the internal repo, all belong to some
>>installed package). As the clients are assigned to certain channels, I
>>would like to add the corresponding repositories again.
>>
>>So far I have tried re-registering the client with
>>
>># rhnreg_ks --serverUrl=https://YourSpacewalk.example.org/XMLRPC
>>--sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
>>--activationkey=<key-with-rhel-custom-channel> --force
>>No success. I have also removed all channel subscriptions, and then
>>added them again, no success.
>>
>>What would be the easiest, or most reliable way to get the correct repo
>>definitions back?
>>
>>Maybe my assumption is wrong, but since the spacewalk client tools have
>>knowledge of the subscribed channels, I assume that there is also a way
>>to get the corresponding repository definitions in some automated way.
>>What would that be?
>>
>>Any hint or feedback is appreciated.
>>
>>Regards,
>>Isaac
>
>It should just work the way you tried. So it would be interesting to know, 
>what error you get when you run the rhnreg_ks tool?
>
>Do you get an error?
>
>If not, do your servers show up as "system" within spacewalk?
>
>If the servers show up in spacewalk, check they really have the channels 
>subscribed. If they do not have channels subscribed, then something's wrong 
>with the activation key.
>
>Robert
>

Unforunatly, rhnreg_ks does not give any output, even with the verbose flag.
The client shows up in Spacewalk (albeit four times - always same UUID, but 
different spacewalk system ID) - with mostly the correct channels. I am not 
sure where the difference in channel config comes from - but that might be due 
to the mess we have here with channel configs. So lets not focus on channel 
correctnes for now - if I get any channel repos configured correctly that would 
mean a big step forward.

Should I have deleted the client bevor re-registering it?

Any place where I could get more logs/output?

Isaac

Attachment: smime.p7s
Description: S/MIME cryptographic signature

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to