Aad Rijnberg wrote:
>     </snip>
>   - from this I see two (different) problems:
>     1) the firmware downloading modem goes wrong
>     2) pppoatm.so is missing
> Do you have any suggestions for next steps that I can take?
> Regards,
> Aad

I'm using Fedora Core 1, but I'll throw in my 2 cents.  The first cent 
is that Fedora Core 2 final is out, so you need to get it.

Next, it looks like you didn't install everything from speedbundle. 
Then again, neither did I, but you still need most of it.  Are you sure 
that everything compiled and installed?  Did you make sure to get the 
necessary firmware (It's not included with speedbundle!)?

You need to move your pppd executables out of the way and install the 
pppd found in speedbundle.  This will place the necessary pppoatm.so 
plugin. But read the rest of this first.

run ./configure from the root of the speedbundle directory.
It will tell you what values you need to fill in the ppp_scripts and if 
you need the firmware file (you do have the firmware file, right?) 
There is a bug in the ppp_scripts, you need to edit speedtch and replace 
the 0.00 with your VPI and VCI numbers for your service.

I think that you need the kernel-source package installed, but I'm not 

Then try to make.  If you get an error on the make, do a make clean, 
re-./configure.  You will most likely fail on the linux-atm or ppp.  If 
that's the case, you don't really need linux-atm (someone correct me if 
I'm wrong; if I'm right, i would suggest leaving it out anyways, I think 
this unnecessarily writes over stuff in your existing kernel), so you 
can make and make install on each of the directories individually, 
leaving out linux-atm.  If you look at the top-level Makefile, you'll 
see how it does this (you'll want to copy its lines).  If the make fails 
on ppp, check the output, it is most likely complaining about the 
kernel.  In that case, you need to use a standard Linux kernel for the 
build rather than the Fedora Linux kernel (don't forget to move your 
original pppd executeables out of the way before installing the new 
pppd).  If you don't want to mess with the standard Linux kernel, this 
website <http://ccrma.stanford.edu/planetccrma/software/>, once updated 
for Fedora Core 2, will have rpms for a kernel that is reasonable close 
enough the standard Linux kernel to work (there will be two versions of 
the kernel on this site, a Fedora-like kernel and a std-Linux-like kernel).

If you still get this error:
>     May 23 08:07:47 localhost kernel: usbfs: process 1608 (modem_run)
>     did not claim interface 0 before use
then I suggest editing /etc/hotplug/usb/speedtch and increase the sleep 

I rebuilt the source RPM from this site, rather than using the 
speedbundle's firmware loader (they are essentially the same, though): 

rpmbuild --rebuild some.src.rpm

The resulting rpm ends up in /usr/src/redhat/RPMS/<your architecture>/
the "redhat" might be "fedora" or something else now that they are on 
Fedora Core 2.  Then I installed the RPM.  If you can still get this to 
work with speedbundle and without the RPM, great, but I couldn't for 
some reason.  If you do install the firmware loaders without the RPM, 
great, but I couldn't get it done.  However, if you do install this RPM, 
be sure to erase the firmware loaders installed by speedbundle.


Liste de diffusion modem ALCATEL SpeedTouch USB
Pour se désinscrire : mailto:[EMAIL PROTECTED]


Reply via email to