Hello Abraham,

You're right. I did not check the response of home_timeline well
enough, I'm sorry for missing that.
However, I'm still having some troubles, let me try to do a better job
on explaining them.

1. The main problem is using users/lookup in a test application in
which I provide authentication by oauth. I get a 404-error as result.
I did however get the oauth-authorization working for other queries,
these give the expected results: statuses/home_timeline, statuses/
user_timeline and friends/ids. So I have specifically a problem with
users/lookup. Maybe I'm doing something wrong here.

2. To check if I did use the right syntax for users/lookup I tried it
in the API console. It seems however the console is not seeing the
parameters/values that I provide. Queries without parameters (like
statuses/home_timeline) give the expected results. However, when I use
a query with user_id as a parameter I don't get the exptected results.
For example I get my own statuses on statuses/user_timeline even when
I provide the parameter/value pair user_id/12345. And I get a "not
found" error for users/show and a "No user matches for specified
terms" error for users/lookup.
In this case I first checked that 12345 is a valid user_id via hurl,
by the url (http://goo.gl/DpWe) Abraham provided, (12345 is used in
some dev.twitter examples too).
However, when I check it on the API console, it seems that the
parameters I provided (user_id-=12345) is not included in the request
header somehow.

3. When using users/lookup directly via 
and providing my username/password in the *basic* authentication popup-
window, this query is working fine.

Again, I guess I'm doing something wrong, but I hope anyone could help
me out. Therefor two questions:

1. Most important: has anyone users/lookup working with oauth-
2. Can anyone check if the API Console sees the parameters that are
provided as input? For instance is users/lookup userid=12345 working
like it does in hurl?

Thanks for your very appreciated help,

Regards, René

On 30 mei, 07:44, Abraham Williams <4bra...@gmail.com> wrote:
> home_timeline always shows the statuses for the authenticated user not the
> user_id you pass in a parameter.
> As you can see there is no user with the id of 0:http://goo.gl/DpWe
> Abraham
> On Sat, May 29, 2010 at 22:33, Abacadabrados <rene.rikk...@gmail.com> wrote:
> > Hello Matt,
> > Thank you for your quick and clear response.
> > However, the user id and screen name are both valid. Both User_id = 0
> > or screen_name = twitterapi work perfectly in the API Console for home/
> > timeline - but not for users/lookup. I also tried it with my
> > screen_name, this works fine with home/timeline but gives a 'No user
> > matches for specified terms' for users/lookup. Maybe I'm doing
> > something wrong. Is the API console users/lookup working for your
> > screen_name at the moment?
> > Regards, René
> > On 30 mei, 01:24, themattharris <thematthar...@twitter.com> wrote:
> > > ...
> > > You need to give the user lookup request some valid user ids or screen
> > > names. The error you are receiving is because you are sending a
> > > user_id of 0 which is not a valid account. Maybe try with your screen
> > > name first.
> > > ...
> --
> Abraham Williams | Developer for hire |http://abrah.am
> @abraham |http://projects.abrah.am|http://blog.abrah.am
> This email is: [ ] shareable [x] ask first [ ] private.

Reply via email to