Dear fellow ICS people...

Apologies... almost "off topic", and very newbie (to TCP/IP), but....

I have a nice little device from PCSensors, their TEMPerLAN. It 
appears to be great engineering, but, out of China, the English of 
the software interface is a lot better than my Chinese, but still a 
little unclear.

Has anyone already worked with this? (A lot to hope for, but you 
never know!)

With software supplied with the device, from a Windows PC connected 
to the same LAN as the TEMPerLAN, I can "send a command" to it. If 
the command is BB 82, I get back a short string of ASCII with some 
data from the device. (Temperatures seen by some attached sensors, 
but that isn't really central to my question!)

So, somehow, their software (it would seem!) is able to send 
something to the device. The software is first "connected" (maybe not 
in the TCP/IP sense) to the device by the device's IP address. 

And then the device sends something out, which is received by the 
monitoring software.

On those slender indications, I certainly don't expect anyone to be 
able to tell me "You just do (this) to duplicate what the software is 
doing".... but if anyone has guesses as to the sort of thing that is 
going on, guesses which could narrow my Google searching, I would be 
very grateful.

And no, sorry to say, if the device is at, as it is, 
putting none of the following into the FireFox address bar work. I 
get "can't connect". (I've tried the 16000 port in the device's 
reported configuration... not in a relevant part, as far as I could 
perceive... but then maybe I was failing to understand parts of what 
the config report was telling me?

First the config report, then the things I've tried. Yes, I do 
realize that I may not be able to "solve" this with a mere browser. I 
have written some very simple TCP/IP programs with ICS already.

Thanks, if only for reading this far!


Config report:

enter config state.
device ipaddress:
device netmask:
device gateway:
host ipaddress:
connection type:tcp
host port:16000 
Product Version:TEMPerLAN V1.1
exit config state.

Unsuccessful browser strings were as follows. The machine the browser 
was running in was at Submask, I think. I 
think both are irrelevant... but maybe that's where I'm going wrong?  /Unable to connect  /Unable to connect /Successful connection to my Arduserver, a different 
device on the LAN, just to be sure I'd got things right!  /Unable to connect  /Unable to connect

If I could have connected, I would have tried things like... 83

.... but there didn't seem to be much point, as I wasn't getting the 

I don't THINK it is my anti-malware software getting in the way.

A PING to DOES get a reply. No reply from 
or .16

Are there other simple DOS commands I should throw at, 
even if 
only to check that a proposed path to my goal of software to send the 
BB 83/ 
read the reply is going to get me there?
To unsubscribe or change your settings for TWSocket mailing list
please goto
Visit our website at

Reply via email to