On 07/28/2018 05:39 AM, Keith Clarke via use-livecode wrote:
Hi Folks,
Is anyone running LS Server on CentOS 6?
I notice that only version 7 is officially supported and not being a Linux 
expert, I’d like to know if this server OS would need to be upgraded before 
attempting anything with LC server on it.
TIA
Keith

The release notes say glibc 2.13 or later is needed to run LC 8 and 9 in Linux. You can check the installed version in a shell locally, or using ssh on a remote machine, with this command:

         ldd --version

The first line it returns tells you the version. On my desktop it returns this, showing glibc is version 2.27:

ldd (GNU libc) 2.27
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

I have a CentOS 7 server running glibc 2.17 and LC server works there. It looks like CentOS 6 ships with 2.12 which won't work.

Good luck!

Warren

_______________________________________________
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Reply via email to