I just went through the instructions from here again:

https://cwiki.apache.org/confluence/display/FLEX/Using+FlexJS+with+IntelliJ+IDEA

It looks like this part is wrong:

1- Click on New Global Library, select <FLEXJS_INSTALL_FOLDER>\frameworks
> and then remove the frameworks\libs\player.
>

I think there are actually many more folders that would need to be removed
from that list with FlexJS 0.8 or newer. I guess no one checked to see if
these instructions were still working correctly or not. I suspect that not
many of us contributors use IntelliJ IDEA for FlexJS.

I think you can get something to work if you add
<FLEXJS_INSTALL_FOLDER>/frameworks/libs instead. Then, remove both
frameworks/libs/player and frameworks/libs/air.

Hey contributors, do any of you use IntelliJ for FlexJS? Is what I've just
said the best way to add the libraries from recent builds of FlexJS? Let's
get those instructions on the wiki updated because they're giving bad info
that will turn new users away!

- Josh


On Tue, Aug 8, 2017 at 11:12 AM, After24 <vinc...@after24.net> wrote:

> Just to be sure, I re-downloaded the nightly in a separate folder and reset
> the project, but unfortunately, I get the same error :
>
> Information:[helloWorldFlexJS]: Starting Flex compiler:
> "/Applications/IntelliJ IDEA.app/Contents/jdk/Contents/Home/jre/bin/java"
> -Dapplication.home=/Users/vincent/development/Apache/flexjs/sdks/0.9.0
> -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en
> -Duser.region=en -Xmx512m -classpath "/Applications/IntelliJ
> IDEA.app/Contents/plugins/flex/lib/idea-flex-compiler-
> fix.jar:/Applications/IntelliJ
> IDEA.app/Contents/plugins/flex/lib/flex-compiler.jar:/
> Users/vincent/development/Apache/flexjs/sdks/0.9.0/lib/
> flex-compiler-oem.jar"
> com.intellij.flex.compiler.FlexCompiler 57530
> Information:[helloWorldFlexJS]: mxmlc
> -load-config=/Users/vincent/Library/Caches/IntelliJIdea2017.2/compile-
> server/helloworldflexjs_890a8fa1/_temp_/IntelliJ_IDEA/
> idea-61249F45-DF3F2E04.xml
> -load-config+=/Users/vincent/development/Apache/flexjs/
> sdks/0.9.0/ide/IDEA/intellij-config.xml
> -targets=JSFlex
> -external-library-path+=/Users/vincent/development/
> Apache/flexjs/sdks/0.9.0/js/libs/js.swc
> Information:[helloWorldFlexJS]: unknown error
> Information:[helloWorldFlexJS]: Compilation failed
> Information:08/08/2017 20:10 - Compilation completed with 5 errors and 0
> warnings in 8s 201ms
> Error:[helloWorldFlexJS]: : interface method addEventListener in interface
> IEventDispatcher is implemented with an incompatible signature in class
> Main
> Error:[helloWorldFlexJS]: : interface method removeEventListener in
> interface IEventDispatcher is implemented with an incompatible signature in
> class Main
> Error:[helloWorldFlexJS]: : interface method dispatchEvent in interface
> IEventDispatcher is implemented with an incompatible signature in class
> Main
> /Users/vincent/development/After24/lab/helloWorldFlexJS/src/Main.mxml
>     Error:Error:[helloWorldFlexJS]: interface method element in interface
> IRenderedObject not implemented by class Main
>     Error:Error:[helloWorldFlexJS]: interface method element in interface
> IInitialViewApplication not implemented by class Main
>
>
>
> --
> View this message in context: http://apache-flex-users.
> 2333346.n4.nabble.com/FlexJS-IDE-integration-tp15638p15657.html
> Sent from the Apache Flex Users mailing list archive at Nabble.com.
>

Reply via email to