Sorry, I guess I skipped a bit of that. 

I did run hosted-engine --deploy and it failed while waiting for vdsm to 
respond and at that point I sent the original email because I wasn't quite 
certain if it was a supported to migrate from non-hosted engine to a hosted 
engine which seems to be possible now (thanks for that link). What I had done 
was leave that engine in place, try to install the hosted engine on a host 
already part of the original non-hosted engine configuration which seems to be 
a bad and somewhat futile path. It looks like the best option for me now if I 
choose to go to a hosted-engine is to use the migration instructions you sent 
and do that, leave it as it is or stand up a seperate cluster and start from 



On Tue, Sep 20 , 2016 at 4:40 PM, Logan Kuhn < > wrote: 

| It's still running on a physical machine. I saw that article, is the way 
| to migrate my physical engine to a hosted engine and then I can deploy more
| hosted engines?

In hosted-engine scenario, the engine is running on a VM hosted by one of the 
hosts it's managing. 
The normal procedure is to run hosted-engine-setup on the first host and it 
will create a VM for you with the engine; hosted-engine-setup will also add 
that host to your engine when available. 

For who deployed in the past we also have a migration procedure. 

Now I don't understand if you still have to try to migrate to hosted-engine or 
if you tried it and something went bad. 

Did you have ever tried to run 'hosted-engine --deploy' on one host? 
Did it completed successfully? 

| Regards,
| Logan

| ----- On Sep 20 , 2016, at 9:36 AM, Simone Tiraboschi < >
| wrote:

|| On Tue, Sep 20 , 2016 at 4:28 PM, Logan Kuhn < > wrote:

||| I tried this and I get the attached error message.

||| Error while executing action: Cannot add Host. You are using an unmanaged 
||| engine VM. Please upgrade the cluster level to 3.6 and wait for the hosted
||| engine storage domain to be properly imported.

||| I used only the required information. Power management is not configured,
||| although even with power management configured (ipmilan) it gives the same
||| error message.

||| The cluster and data center compatibility levels are at 4.0.

||| I also created a new data center and cluster and the problem continues. This
||| installation was done via engine-setup and is on a physical machine, not a
||| hosted-engine itself. Is that the problem?

|| Sorry, but do you mean that you initially deployed the engine on a physical
|| machine and then you migrated your setup to an hosted-engine scenario 
|| [1] or is your engine still running on a physical machine?

|| [1] -

||| Regards,
||| Logan

||| ----- On Sep 19 , 2016, at 3:06 PM, Simone Tiraboschi < 
||| wrote:

|||| On Mon, Sep 19 , 2016 at 9:53 PM, Logan Kuhn < > wrote:

||||| I understand and I would prefer that as well, but for the life of me I 
||||| seem to find where that is available in the web admin.

|||| See the attached picture.

||||| Regards,
||||| Logan

||||| ----- On Sep 19 , 2016, at 2:44 PM, Simone Tiraboschi < >
||||| wrote:

|||||| On Mon, Sep 19 , 2016 at 6:59 PM, Logan Kuhn < > 

||||||| When I try to deploy a second hosted engine it errors out at 
Environment, items.
||||||| Full log attached.

||||||| The host I'm deploying to is actually going to end up being our 
||||||| instance of the image. I've also tried to install it on a currently 
||||||| VM host with the exact same error message.

||||||| Regards,
||||||| Logan

|||||| Hi Logan,
|||||| could you please try with
|||||| from 4.0.3 RC3?

|||||| Patch should also address your issue.

|||||| In general with 4.0 I'd strongly suggest to deploy additional 
|||||| hosts directly from the engine web admin instead of using 
|||||| also there.

||||||| _______________________________________________
||||||| Users mailing list
Users mailing list

Reply via email to