On Thu, 7 May 2026 21:39:14 GMT, Coleen Phillimore <[email protected]> wrote:

>> Add a bunch of stubs and parameter changes to get non-Oracle platforms to 
>> compile.  Tested with cross compilation in mach5.  Also enabled GHA for 
>> these platforms.  Tested tier1 with Oracle platforms.
>> 
>> Porters please let me know if this runs hello world, then the rest is up to 
>> you.
>> Thank you!
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Coleen Phillimore has updated the pull request incrementally with two 
> additional commits since the last revision:
> 
>  - include another file.
>  - Some forward declarations might do the trick.

I'm not super familiar with this code, but GitHub Actions seems to be happy 
with the compilation, so I'm happy. I've left some smaller comments, but I 
think Dean has very valuable feedback.

src/hotspot/cpu/aarch64/macroAssembler_aarch64.hpp line 1501:

> 1499:   #include "asm/macroAssembler_common.hpp"
> 1500: 
> 1501:   int store_inline_type_fields_to_buf(ciInlineKlass* vk, bool 
> from_interpreter = true);

Are these methods unused?

src/hotspot/cpu/arm/sharedRuntime_arm.cpp line 505:

> 503:   int total_args_passed = sig->length();
> 504:   for (int i = 0; i < total_args_passed; i++) {
> 505:     BasicType bt = sig->at(i)._bt;

Is this just a cleanup to make the code more readable?

src/hotspot/cpu/ppc/continuationEntry_ppc.inline.hpp line 30:

> 28: #include "runtime/continuationEntry.hpp"
> 29: 
> 30: #include "code/codeCache.hpp"

This doesn't seem very Valhalla-related at a glance. What happened?

src/hotspot/cpu/ppc/frame_ppc.hpp line 411:

> 409:     // size, in words, of maximum shift in frame position due to 
> alignment
> 410:     align_wiggle                           =  1,
> 411:     // This is wrong and unimplemented

A little bit more context would be nice, "this is wrong" doesn't really say 
much. Then again, I'm not familiar with PPC frame code!

src/hotspot/cpu/ppc/sharedRuntime_ppc.cpp line 1100:

> 1098:   // rest through register value=Z_R12.
> 1099:   BLOCK_COMMENT("Shuffle arguments");
> 1100: 

Extra whitespace?

src/hotspot/cpu/riscv/interp_masm_riscv.cpp line 1596:

> 1594:         // CallTypeData/VirtualCallTypeData to reach its end. Non null
> 1595:         // if there's a return to profile.
> 1596:         assert(SingleTypeEntry::static_cell_count() < 
> TypeStackSlotEntries::per_arg_count(), "can't move past ret type");

Nit: "single type" in the assert message.

src/hotspot/share/asm/macroAssembler_common.hpp line 53:

> 51:                                  VMRegPair* regs_from, int from_index, 
> int regs_from_count, RegState* reg_state);
> 52: 
> 53:   int store_inline_type_fields_to_buf(ciInlineKlass* vk, bool 
> from_interpreter = true);

Oh I see this was moved around to become common code.

-------------

Marked as reviewed by phubner (Committer).

PR Review: 
https://git.openjdk.org/valhalla/pull/2396#pullrequestreview-4251138208
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207734898
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207756963
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207853593
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207824329
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207802101
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207797995
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3207780527

Reply via email to