On Fri, 8 May 2026 09:32:35 GMT, Paul Hübner <[email protected]> wrote:

>> Coleen Phillimore has updated the pull request incrementally with two 
>> additional commits since the last revision:
>> 
>>  - include another file.
>>  - Some forward declarations might do the trick.
>
> src/hotspot/cpu/arm/sharedRuntime_arm.cpp line 505:
> 
>> 503:   int total_args_passed = sig->length();
>> 504:   for (int i = 0; i < total_args_passed; i++) {
>> 505:     BasicType bt = sig->at(i)._bt;
> 
> Is this just a cleanup to make the code more readable?

Yes and no.  I could have changed sig_bt[i] to sig->at(i) everywhere but 
instead replaced to have a local BasicType bt.

-------------

PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2396#discussion_r3210534800

Reply via email to