Rick Widmer wrote:
> John Simpson & Robin Bowes
> Do you really want the onchange function to be called three times on an
> add_domain operation, and two times on an add_user operation? I find it
> problematic that you are notified of the mod_user before the add_user,
> and personally would prefer only one call per operation. (That means
> you have to assume the postmaster user was added when you add a domain.)
> At the very least I would like to block the mod_user notification in an
> add_user operation. I think it is a good idea to block the add_user
> [EMAIL PROTECTED] operation on an add_domain too. I'll handle coding it
> if it is ok with you two.
I must admit I've not actually looked at John's code.
However, my thoughts (based on your comments) are as follows:
add_user should be called as well as add_domain when a new domain is
created - these are separate actions that happen to both occur when you
first create a domain.
I don't really have a problem with both mod_user and add_user triggering
in an add_user operation. What happens to cause mod_user to trigger as
well as add_user? I guess the user is added and then modified - the
password is set, perhaps? BUt I would need to look at the code to see
what actually happens. Bottom line; If the user is being added and then
modified then it makes sense to have both hooks triggered.
Why do you want to change this?
What is the problem you are trying to solve?
> If --enable-onchange-script is added to the ./configure command
> many vpopmail commands, and calls into the library will call the
> script ~vpopmail/etc/onchange when they have completed execution.
> When the script is called, it will be passed the following values
> on the command line to indicate what was changed.
> add_user [EMAIL PROTECTED]
> add_domain domain
Does there need to be a "del_alias_domin" hook? How about a mod_domain,
or mod_alias_domain (not sure if these two would be necessary)?
> valias_insert [EMAIL PROTECTED]
What's the difference between valias_remove and valias_delete ?
Does there need to be a valias_mod?
Why is this not add_valias, del_valias? (to make it the same as the
user/domain hooks) ?