Rick Widmer wrote: > Robin Bowes wrote: >> Having thought about this some more, I think that a better approach >> would be to have both pre- and post- hooks for each action and to call a >> separate script for each hook. > > This has some possibilities. There would be an advantage if most of the > hooks were empty, and a liability if there was a lot of duplicate code. > It would require several identical files to support John's existing > setup. I'm happy with a single script and a switch() on the command > that was executed.
If you have duplicate code you would just symlink a single script containing your switch() statement - best of both worlds! > > I would still argue that the hooks should match the calls in the vopmail > api, and not an arbitrary subset of the operations within them. Why? Why not make the hooks reflect the "useful" operations rather than just what goes in internal to vpopmail? >> Why not just store the whole .qmail as a multi-line text object? > > The biggest problem, it would break every program that currently updates > valias entries. The other minor detail, can every back end support it? > I don't know. I use CDB, test mysql and pgsql, and can't even list > all the other back ends off the top of my head. I have no idea how you > would implement valias in them, and I don't believe any of them have it > yet. There is very little interest in keeping them current with the big > three. They usually get updated just enough to scratch the itch of the > person who contributes a patch... unless you want it bad enough to pay. > Inter7 and Tom Collins will both do sponsored work that usually finds > its way back into the distribution. It was just an idea - I don't know the details of the code. R.