Hi Andy.  First, let me thank you once again for sticking with this ongoing 
saga.  Next time I'm in North Carolina, I'll buy you a beer!

On 2 Mar 2010, at 0831h, Andy Kurth wrote:

> You will need to watch the VM console after the VM is turned on in order to 
> troubleshoot this.  You should see the following:
> 
> -VM is turned on
> -Sysprep minisetup runs, VM is rebooted
> -When Windows boots up for the first time, the root account is automatically 
> logged on
> -A few black command boxes appear on the desktop, the one in the back is 
> named post_load.cmd
> -When the command boxes close, root is logged off
> -At this point, the computer should respond to SSH

I see the VM turn on, sysprep runs, VM reboots, but then after Windows loads it 
just stays at the login window.

> You should be able to log on as root via the VMware console.  The password 
> should be the one configured as WINDOWS_ROOT_PASSWORD /etc/vcl/vcld.conf.  
> After logging in, view the log files generated by the VCL scripts.  All of 
> the output generated by the scripts gets saved into files in 
> C:\cygwin\home\root\VCL\Logs.

I can indeed login as root via the console, with the password I put in 
vcld.conf.  However, there is no log folder in C:\cygwin\home\root\vcl - just 
Drivers, Scripts, Security and Utilities.  Which, after poking around a bit, 
means that post_load has not run, yes?

If I run post_load manually, everything seems to move along nicely, but after 
it logs out, I can no longer login as root.  It doesn't let me type a password, 
even though it's asking for one.

Interestingly, if I make a reservation at this point, the reservation appears 
to be set up properly, and is acknowledged through the web interface, but when 
I try to login via RDC, it fails, acting like there's no machine to talk to.  
(And, yes, I'm trying to connect from the same machine I clicked the "Connect!" 
button on.)  The vcld log suggests all is well (there's lots of log, as you'd 
know - let me know if I should send you any of it.)

Trying to ssh or ping the vm on its public address fails, but that might be 
normal, yes?

> The troubleshooting steps depend largely on whether or not you see root being 
> automatically logged on.
> 
> If root is not logged on automatically, the problem can probably be found in 
> sysprep_cmdlines.log and the files in Logs\sysprep_cmdlines directory.  These 
> files are generated during the Sysprep minisetup stage when 
> Scripts\sysprep_cmdlines.cmd runs.  This script configures root's autologon 
> and sets a registry key to cause Scripts\post_load.cmd to run after root is 
> automatically logged on.


> If it's attempting to log on root but failing because of a credentials 
> problem, the cause could be that the password was not correctly configured in 
> Scripts\autologon_enable.cmd.  Check the "set PASSWORD=" line in this file.

The autologin_enable script has the correct password, and when I run it then 
restart, autologin works.

> If root is being logged on, first check if the Cygwin SSHD service is running 
> and if the firewall has an exception for TCP port 22.  Be sure to check both 
> the middle "Exceptions" tab and the settings for each adapter under the 
> "Advanced" tab for the exception.  My guess is that SSHD failed to start.  
> The problem can probably be found in Logs\post_load.log and in the files in 
> the Logs\post_load directory.  Check Logs\update_cygwin.cmd for errors.
> 
> As you'll see in the log files, there's a lot that has to happen in order for 
> everything to work correctly.  The output from the log files will be helpful 
> in order to figure this out.

Poking around in the scripts folder, I see that this whole post-load series of 
events is contingent on Sysprep running sysprep_cmdlines, which perhaps it's 
not doing.  Does it matter that the sysprep.inf file includes 
"InstallFilesPath=C:\sysprep\i386"?  This doesn't seem right to me, but to 
change it I'd need to alter the base image, which frightens me.  So, I'll await 
your reply before trying anything that crazy.

Terry

Reply via email to