Hi Terry,
Is the image booting on vmguest-2 and 3 but SSH is failing, or is it not booting at all? If it isn't booting, check the computer.drivetype values for the VMs. I came across an issue with this last week with another pilot attempting to create a Linux VMware base image. If the value differs among the VMs, try swapping sda/hda and see what happens.

If the image is booting but SSH isn't responding, check the MAC addresses and IP addresses that are assigned to the VMs. If it isn't receiving an IP address, do the private MAC addresses match dhcpd.conf and /etc/hosts? Also, check the VM host to make sure you don't have multiple instances of a VM using the same MAC address.

I'm not sure what's causing the "Failed to resolve given hostname" error. I'm guessing this is coming from the nmap command. Was this error listed in vcld.log or did you see it somewhere else? Please provide some lines leading up to this error if it's from the log.


Terry McGuire wrote:
Hi Andy (and anyone else following along here).  I've been doing a lot of 
poking around, and, long story short,  I can now (for the first time ever) 
successfully book and log into the Windows image (yay!) but, annoyingly, only 
with a single one of the vm guest computers I've configured.

While stumbling around in the dark, I decided to try setting up a Linux base image as 
well as the Windows one.  The process went much quicker, but, unfortunately, it seems to 
be getting hung up in a similar place to the Windows image, but that's not the 
interesting thing.  When I created the Linux image, I created a new vm guest to run it on 
("vmguest-2").  When I got tired of playing with the Linux image, I switched 
back to the Windows image, and, to my amazement, it worked!  And then I realized that it 
was loading on vmguest-2.  Still didn't work on vmguest-1.  I created yet another vm - 
vmguest-3 - but it also won't work on it.  Only vmguest-2.  I can't quite figure out 
what's special about it.  I even swapped the private ip addresses, so vmguest-1 had 
vmguest-2's address, same result.  (And, with the wiki down at the moment, I can't get to 
the Linux base image documentation to see if there was something special about how I made 
the vm in the first place.)

As well, the errors I get are different on vmguest-1 and 3.  On 1, it can't ssh 
into the machine, as before.  On 3, it starts giving me these:

Failed to resolve given hostname/IP: vmguest-3.  Note that you can't use 
'/mask' AND '1-4,7,100-' style IP ranges
WARNING: No targets were specified, so 0 hosts scanned.

To my newbie eyes, all three vm computers are all as identically configured in 
the vcl computers tables as possible under the circumstances.

Another thing (though probably not related): The machines all come up with 512MB memory, but I've set them to have 1024MB. Clearly, I'm missing some config info somewhere.
At this point it seems I have a useful situation for continued debugging:  a 
working setup, but only for the Windows image, and only for a single VM.  
There's *gotta* be a way to figure out what's the difference making the 
difference.  I'm not worrying about the Linux image right now.  I figure, once 
I get Windows images running properly, I'll have a much easier time getting 
Linux working.

On a (related) side note, I see the list is getting much busier with newbies 
like me asking newbie questions.  A mixed blessing?  Obvious interest in the 
product, but a whole lot of support work for you, huh?  Once I actually have a 
clue, I fully intend to start contributing back, to help with this situation.


On 7 Apr 2010, at 1418h, Andy Kurth wrote:

Is SSH working and is everything being processed by vcld to the point where you 
see the Connect button on the web page?  If you are just manually running the 
scripts then RDP won't be available because the firewall port isn't open.  vcld 
opens it later on in the process.

I have not seen the error before in the output from IP config called from 
"An internal error occurred: The file name is too long."

I'm wondering if a problem occurred obtaining the IP address.  Can you run "ipconfig /all" manually 
and does this error show up?  If SSH is working correctly on the private interface, then I'm guessing there 
is a routing table problem.  There are no 129.x entries.  This seems odd.  Do any entries appear for 129.x in 
the routing table it you run "ipconfig /renew", then "route print"?

If vcld is completely loading the computer, then the problems that occur in 
configure_networking.vbs may not be the problem.  The output from the log file where 
"set_public_default_route" is called will be helpful.  The .vbs script attempts 
to set default routes but the vcld code does this again later on.

Andy Kurth
Virtual Computing Lab
Office of Information Technology
North Carolina State University

Reply via email to