Note:  I am not on this mailing list, please add
neal.pollack at in reply.


- bugs vs build 129
- need updated web pages (30 builds old),
- need better user guide

HW config:
x64 desktop running build 129 OpenSolaris and Nvidia graphics card.


Today, for the first time, I wanted to try virtual consoles.
I went to the project pages on;

I could not find information that is current.
So they I read the man page, and tried enabling
svcadm enable svc:/system/console-login:vt2

It failed.
When I typed svcs -xv, I found that SMF did not
enable the dependant service;
root at zbit:~# svcs -xv
svc:/system/vtdaemon:default (vtdaemon for virtual console secure switch)
 State: disabled since December 14, 2009 11:07:27 AM PST
Reason: Disabled by an administrator.
   See: man -M /usr/share/man -s 1M vtdaemon
Impact: 3 dependent services are not running:

So I had to manually enable;
# svcadm enable svc:/system/vtdaemon:default

I then tried, as per the man page,  ALT + F2.  Nothing.
So then I tried ALT + CNTRL + F2 and the display (Xorg?)
crashed.  Nothing could reset the display except for
hardware reset of system.
I repeated this process and gave up.

So, the real questions are;

- Does virtual console project work with OpenSolaris build 129?

- If so, where is a simple "step by step" guide for turning it on.

- Why is it not on-by-default?

- Does it get tested with each new build of OpenSolaris?

- Why does the dependant vtdaemon service not get automatically
  started when I svcadm enable console-login:vt2?  The entire idea
  behind SMF was to automatically handle dependencies.

Sincere Thanks,

Note:  I am not on this mailing list, please add
neal.pollack at in reply.

Reply via email to