First at the interface level, you need to enable WMM.

Then I set up the following rules which ensures that DSCP sets layer 2 priority WMM needs:

"/ip firewall mangle
add action=set-priority chain=prerouting comment="VoIP WMM " disabled=no new-priority=from-dscp passthrough=yes protocol=\
    udp "

Most VoIP services tend to use DSCP of 46.

Then I set a somewhat broadbase firewall/queue rule which basically says UDP packets should get preference since 99.9% of VoIP is UDP and I make it the first queue rule before all others.

"/ip firewall mangle> add action=mark-packet chain=forward comment=VoIP disabled=no in-interface=ether1 new-packet-mark=VoIP \
    passthrough=no protocol=udp"

"/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \ limit-at=0/0 max-limit=0/0 name="VoIP Traffic" packet-marks=VoIP parent=none priority=1 queue=synchronous-default/synchronous-default \
    total-queue=default-small"

These rules can be massaged quite a bit to be more specific since a lot of other apps use UDP too. Some things we'll do to make the rule more specific is find out the users VoIP provider and then setup the queue based on the VoIP's IP block.

On 09/14/2010 07:36 AM, Jeremie Chism wrote:
What specific rules did you add for your voip.

Sent from my iPhone

On Sep 14, 2010, at 5:21 AM, Bret Clark <bcl...@spectraaccess.com <mailto:bcl...@spectraaccess.com>> wrote:

We enabled it both in the CPE and AP. We also added queue rules in both the CPE and AP to ensure that VoIP traffic got priority not just at layer 2, but layer 3.

On 09/13/2010 10:43 PM, RickG wrote:
Did you do that in your firewall, the ap, or both?

On Mon, Sep 13, 2010 at 2:25 PM, Bret Clark <bcl...@spectraaccess.com <mailto:bcl...@spectraaccess.com>> wrote:

    We enabled WMM on our Mikrotik's and then just added a Mangle
    rule to
    ensure the DSCP was marked correctly, this solved VoIP issues
    for our users.


    On 09/13/2010 02:20 PM, Josh Luthman wrote:
    > I see, you're talking about quality not raw speeds - you said
    > "complaints about slowdowns".  I would say TDMA would be the
    best bet
    > to solve this problem cost effectively.
    >
    > If you half the channel size, half the number of clients.  Not the
    > other way around.
    >
    >
    >> Can the UBNT co-exist
    >>
    > Contract issues says he can only replace the radio, not add
    more equipment.
    >
    > Josh Luthman
    > Office: 937-552-2340
    > Direct: 937-552-2343
    > 1100 Wayne St
    > Suite 1337
    > Troy, OH 45373
    >
    >
    >
    > On Mon, Sep 13, 2010 at 2:17 PM, John Vogel<jvo...@vogent.net
    <mailto:jvo...@vogent.net>>  wrote:
    >
    >> Can the UBNT co-exist with MT APs in the same environment or
    will the UBNT
    >> wipe out all other 802.11x based APs on nearby channels
    within hearing
    >> distance?
    >>
    >> On 9/13/2010 1:10 PM, Forbes Mercy wrote:
    >>
    >> > From personal experience I can tell you that you will be
    very happy when
    >> you make the switch.  I just replaced three Mikrotik BH/AP
    units, pings went
    >> from their rather wild 30-120ms swings to a steady 15ms no
    matter what
    >> time.  Just be ready for three things, you can't put
    usernames in the ACL
    >> like Mikrotik, there is less routing because UBNT expects
    filtering to be
    >> done in your router before their equipment, and it will never
    go down
    >> because it's just a transparent bridge so traffic that would have
    >> overwhelmed Mikrotik equipment and crashed the LAN port won't
    happen on
    >> Ubiquity.  Oh and you're right, I've found that if you use
    dual-polarity you
    >> can't mix that with non-dual and connections with non-, its
    far better to
    >> have all Airmax running rather than a mix, this means
    replacing CPE so that
    >> all customers on that tower are the same equipment, spendy
    (relative to
    >> UBNT's low cost) but worth it.
    >>
    >> Forbes Mercy
    >> Washington Broadband
    >>
    >> On 9/13/2010 10:31 AM, Steve Barnes wrote:
    >>
    >> All my APs are Mikrotik. My CPE’s are a mix of Tranzeo and
    UBNT.   I have a
    >> AP with 58 Clients on it and starting to get complaints about
    slowdowns.
    >> They are all setup 10 MHz channel 802.11g.  This is a tower
    that due to
    >> contractual issues I cannot add anymore equipment.  So I am
    considering
    >> taking down the Mikrotik and 120 degree sector and putting up
    a UBNT Rocket
    >> and Airmax 120 sector.  It will take time to physically
    switch all my
    >> clients to new UBNT Airmax equipment but would like to get it
    done before
    >> the snow flies.
    >>
    >>
    >>
    >> Has anyone down this?  Success?  I know I cannot turn on
    Airmax till
    >> everyone is on the UBNT with that capability but does it work
    fine till you
    >> get it on?
    >>
    >>
    >>
    >> Steve Barnes
    >>
    >> RC-WiFi Wireless Internet Service
    >>
    >>
    >>
    
--------------------------------------------------------------------------------
    >> WISPA Wants You! Join today!
    >> http://signup.wispa.org/
    >>
    
--------------------------------------------------------------------------------
    >>
    >> WISPA Wireless List: wireless@wispa.org
    <mailto:wireless@wispa.org>
    >>
    >> Subscribe/Unsubscribe:
    >> http://lists.wispa.org/mailman/listinfo/wireless
    >>
    >> Archives: http://lists.wispa.org/pipermail/wireless/
    >>
    >>
    >>
    >>
    
--------------------------------------------------------------------------------
    >> WISPA Wants You! Join today!
    >> http://signup.wispa.org/
    >>
    
--------------------------------------------------------------------------------
    >>
    >> WISPA Wireless List: wireless@wispa.org
    <mailto:wireless@wispa.org>
    >>
    >> Subscribe/Unsubscribe:
    >> http://lists.wispa.org/mailman/listinfo/wireless
    >>
    >> Archives: http://lists.wispa.org/pipermail/wireless/
    >>
    >>
    >>
    >>
    
--------------------------------------------------------------------------------
    >> WISPA Wants You! Join today!
    >> http://signup.wispa.org/
    >>
    
--------------------------------------------------------------------------------
    >>
    >> WISPA Wireless List: wireless@wispa.org
    <mailto:wireless@wispa.org>
    >>
    >> Subscribe/Unsubscribe:
    >> http://lists.wispa.org/mailman/listinfo/wireless
    >>
    >> Archives: http://lists.wispa.org/pipermail/wireless/
    >>
    >>
    >
    >
    
--------------------------------------------------------------------------------
    > WISPA Wants You! Join today!
    > http://signup.wispa.org/
    >
    
--------------------------------------------------------------------------------
    >
    > WISPA Wireless List: wireless@wispa.org
    <mailto:wireless@wispa.org>
    >
    > Subscribe/Unsubscribe:
    > http://lists.wispa.org/mailman/listinfo/wireless
    >
    > Archives: http://lists.wispa.org/pipermail/wireless/
    >



    
--------------------------------------------------------------------------------
    WISPA Wants You! Join today!
    http://signup.wispa.org/
    
--------------------------------------------------------------------------------

    WISPA Wireless List: wireless@wispa.org <mailto:wireless@wispa.org>

    Subscribe/Unsubscribe:
    http://lists.wispa.org/mailman/listinfo/wireless

    Archives: http://lists.wispa.org/pipermail/wireless/





--------------------------------------------------------------------------------
WISPA Wants You! Join today!
http://signup.wispa.org/
--------------------------------------------------------------------------------

WISPA Wireless List:wireless@wispa.org  <mailto:wireless@wispa.org>

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives:http://lists.wispa.org/pipermail/wireless/



--------------------------------------------------------------------------------
WISPA Wants You! Join today!
http://signup.wispa.org/
--------------------------------------------------------------------------------

WISPA Wireless List: wireless@wispa.org <mailto:wireless@wispa.org>

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/




--------------------------------------------------------------------------------
WISPA Wants You! Join today!
http://signup.wispa.org/
--------------------------------------------------------------------------------

WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/


--------------------------------------------------------------------------------
WISPA Wants You! Join today!
http://signup.wispa.org/
--------------------------------------------------------------------------------
 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Reply via email to