Hi Bill and all,

I thought that those who build on OS X might find this of interest. 

I was unable to build on OS X 10.11.6 after updating to Xcode 8 (from Xcode 7). 
The cmake configuration would fail when testing gfortran, due to a linker 
error. The error message was " ld: unexpected token: !tapi-tbd-v2 file”. I 
tried both the Xcode linker in /usr/bin and the Macports-installed gcc5 linker 
in /opt/local/bin and got the same error message. I was able to get it to work 
by using macports to install the “ld64_xcode" variant of ld64: sudo port 
install ld64 +ld64_xcode.

Strangely, I had no problem on my laptop when I updated to Xcode 8 a few weeks 
ago. However, I don’t think that I have done a configuration from scratch on 
that machine since I updated Xcode. Maybe the same problem would crop up there 
if I tried to configure.

In any case, maybe this information will save someone else some time.

Steve k9an

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
wsjt-devel mailing list

Reply via email to