On Sat, 12 Sep 2009, Eric Schrock wrote:

> Your statement that it is "just fine" is false:

I didn't say it worked "perfectly", I said it worked "fine". Yes, it gave a
*warning* that the "SMART Selective Self-Test Log Data Structure Revision
Number" was 0 instead of 1, **however** other than that warning the data
smartctl returned from the drive appeared correct.

Results from the virgin drive:

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

Results after manually initiating self tests:

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)
# 1  Extended offline    Completed without error       00%        68
# 2  Short offline       Completed without error       00%        68

The exact same drive in the x4500 running your test program to check
self-test results:

self-test-failure = (embedded nvlist)
        nvlist version: 0
                result-code = 0x4
                timestamp = 0x48a5
                segment = 0x0
                address = 0xa548a548a548
        (end self-test-failure)

There's definitely invalid data all right, but it's **not** originating
from the drive.

For that matter, the warning is about the "SMART Selective Self-Test Log
Data Structure Revision Number", not the "SMART Self-test log structure
revision number" -- which is correctly version 1.

> Like I said, there are ways we could tighten up the FMA code to better
> handle bad data before going off the rails - most likely smartctl gives
> up when it sees this invalid record, while we (via SATL) keep going.
> But any way you slice it, the drive is returning invalid data.

The drive is not returning invalid data in a Linux box running smartctl.
Other than a *warning* about the wrong revision of a data structure for a
different self test, the drive seems to work just fine.

I really appreciated the help you provided with figuring out what was going
on with this drive in an x4500 under Solaris. I understand there's no
obligation on anybody's part to make this unsupported drive work. However,
given it does work correctly (at least in regards to returning smart
self-test logs) under Linux, I don't see why it could not work correctly
under Solaris. If it doesn't get fixed, it doesn't get fixed, but I don't
understand why you're saying the drive is returning invalid data when the
evidence does not support that conclusion.

Paul B. Henson  |  (909) 979-6361  |  http://www.csupomona.edu/~henson/
Operating Systems and Network Analyst  |  hen...@csupomona.edu
California State Polytechnic University  |  Pomona CA 91768
zfs-discuss mailing list

Reply via email to