yuppie wrote: > Based on the discussion on the Five list I propose this solution: > > 1.) To become independent of the lookup order views are named different > than the corresponding skin methods. > > 2.) Skins *and* views are always enabled. > > 3.) A new extension profile hooks up the views instead of the skin methods.
This seems like an elegant solution. > Enabling Five traversal and views by default is a big change so we might > need an other beta release. I would strongly suggest that. > Some details: > > - I'd like to keep the changes the extension profile makes as small as > possible. So I don't want to change the visible action targets. All we > need are some Method Aliases that point to the views. > > - We need new names for the views. I'd like to use @@view.html, > @@edit.html and @@properties.html for the views that already exist. +1 for saner view names. "document_view" or "document_edit_form" is just a lame legacy from the one flat view namespace that portal_skins provide. By the way, unless you make @@view.html the default view name for documents or whatever (using five:defaultViewable and browser:defaultView), why not call it @@index.html?? Philipp _______________________________________________ Zope-CMF maillist - Zope-CMF@lists.zope.org http://mail.zope.org/mailman/listinfo/zope-cmf See http://collector.zope.org/CMF for bug reports and feature requests