> Yes. ZPsycopgDA can be under the ZPL because the ZPL is GPL-compatible.
> But if you directly include GPL'ed code you must use GPL.
OK. Thanks for the answer. One more question.
If I'll create application using ZPsycopgDA which
is ZPL (but ZPsycopgDA uses psycopg which is GPL),
then does my application have to be GPL too?

Federico, as I see you're one of psycopg2 developers so
a little question about this. I've found a bug in
ZPsycopgDA. It should have one more statement
when catching exceptions:
if e.args[0].find("deadlock detected") > -1:
    raise ConflictError

There are two places in ZPsycopgDA/db.py
where above code should be added. These are near:
if e.args[0].find("concurrent update") > -1:
    raise ConflictError

Can I submit this issue somewhere (AFAIK there
is no bugtracker at initd.org) or this e-mail
is enough?

The problem is in psycopg2.
Zope3 psycopg implementation
already has such statement.

Maciej Wisniowski
Zope-DB mailing list

Reply via email to