----- Original Message -----
From: "Andre Schubert" <[EMAIL PROTECTED]>
To: "Andreas Jung" <[EMAIL PROTECTED]>
Sent: Wednesday, August 21, 2002 8:06 AM
Subject: Re: [Zope-dev] Zope 2.4.3 and Python 2.2

> On Wed, 21 Aug 2002 07:52:30 +0200
> "Andreas Jung" <[EMAIL PROTECTED]> wrote:
> > Use Python 1.5.2 with Zope 2.4.X and Python 2.1.3 for
> > Zope 2.5.X. Any other combination is *not* supported.
> Why use Zope 2.4.X with Python 1.5.2 when i could find RPMs
> on zoep.org that requires Python 2.1.x ?
> And yes i know that this is not supported, but could there anything
> incompatible between Python 2.1 + Zope and Python 2.2 + Zope ?
> Greets,

Because Zope 2.4.3 depends on Python 1.5.2 and will break with newer pythons
(this has been experienced by others). Similarely if you use Zope 2.5.x, you
need to use Python 2.1.3, because that python contains bugfixes that
specifically affects Zope's stability.

Zope 2.5.x and 2.4.x will not work with python 2.2x either, due to
incompatibilities with python 2.2.

Also, if you are using python 2.1.3, you probably want to install it from
source, and configure it by passing the --without-pymalloc directive to the
configure script.

I cannot really remember why this is necessary, but I have some faint memory
of some incompatibility between the newer optimised memory management
thingie in python 2 and zope... or something like that :-)


- --------------------------------------------------------------------
Dario Lopez-Kästen, [EMAIL PROTECTED]        IT Systems & Services
System Developer/System Administrator     Chalmers University of Tech.

Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to