> FYI, the current CVS head (to be 2.7) now requires 2.2.2 as per an > earlier papal edict. So there will be at least some work involved in > making it run under 2.1.3.
I know. It's not much work, and I have already volunteered to do it. Jim has explicitly undone that decision and told me it's Brian's call now. > I kindof feel like we already made a rather firm commitment to > *requiring* 2.2.x. I did not fully agree with that decision at the > time, but to renig on it now seems fairly counterproductive unless > someone can provide a really good reason. I also did not agree at the time. I don't see how it can be counterproductive to change a broken decision. > I personally feel like Zope should run on 2.2.x whether required or > not. Requiring 2.2.x does have the advantage of limiting the > possible blessed configurations on which Zope will run, thereby > making development, support and bug fixing that much easier. I *also* volunteer to make sure that *to the limits of my knowledge* Zope 2.7 indeed continues to run under Python 2.2.2. > Otherwise I can see having to develop on Python 2.1.x and test on > 2.1.x and 2.2.x. It would be nice not to have to do this when > developing 2.7 only code. I realize that this would be necessary > when backporting things to 2.6. --Guido van Rossum (home page: http://www.python.org/~guido/) _______________________________________________ Zope-Dev maillist - [EMAIL PROTECTED] http://lists.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists - http://lists.zope.org/mailman/listinfo/zope-announce http://lists.zope.org/mailman/listinfo/zope )