On Monday 13 January 2003 09:56 am, Guido van Rossum wrote:
> > What would the arguments be for sticking with Zope 2.1.3 for Zope 2.7? I
> > feel most people want to use the latest and greatest versions, usually...
> Actually, most people don't care about the latest and greatest, and
> would prefer tried and trusted.  Especially if the latest and greatest
> means they have to install more stuff.
> > Or?
> > 
> > Of course, if the requirement could be 2.1.3 *or* 2.2.2, that would
> > be nice, but is that realistic?
> In practice, Zope 2.6(.x) already fulfills this requirement, it's only
> that ZC doesn't have the resources to guarantee it.  I think 2.7 would
> be in the same boat.

FYI, the current CVS head (to be 2.7) now requires 2.2.2 as per an earlier 
papal edict. So there will be at least some work involved in making it run 
under 2.1.3.

I kindof feel like we already made a rather firm commitment to *requiring* 
2.2.x. I did not fully agree with that decision at the time, but to renig on 
it now seems fairly counterproductive unless someone can provide a really 
good reason.

I personally feel like Zope should run on 2.2.x whether required or not. 
Requiring 2.2.x does have the advantage of limiting the possible blessed 
configurations on which Zope will run, thereby making development, support 
and bug fixing that much easier.

Otherwise I can see having to develop on Python 2.1.x and test on 2.1.x and 
2.2.x. It would be nice not to have to do this when developing 2.7 only code. 
I realize that this would be necessary when backporting things to 2.6.


Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists -
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to