On Wed, 03 Dec 2003 20:43:23 +0100
Yuppie <[EMAIL PROTECTED]> wrote:

> So I think it would be great if VHM would add a variable like 
> 'REQUESTED_URL' (should have a better name) that isn't further modified 
> on traversal.
> 'http://example.org/test/path/to/object'


I actually had a case recently where using traverse_subpath in a python script screwed 
up CookieCrumbler (which uses REQUEST.URL to determine where it should redirect). 
Basically it ate the end of the URL value so the login form redirected to the wrong 

The evil hack fix was actually a REQUEST.set('URL', ...), in the python script before 
any unauthorized errors could be raised. Perhaps it should be called "ACTUAL_URL" or 
"ORIGINAL_URL". This would be the thing that CookieCrumber would redirect to...


Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to