Aaron Lehmann a écrit :


On Feb 26, 2008, at 9:38 AM, Christophe Combelles wrote:

Martijn Faassen a écrit :
(...)

The two easiest choices are 1) issue a clear warning in stderr, or 2) rename 'develop' to something else.

So, the people that understand either get spammed with warning messages every build,

You would get a warning *only* if you have specified a 'develop' option and that option has no effect (because of a version). I suppose nobody work in such a situation because it makes no sense. Either you want to specify a version to let your develop-egg be used, or you just remove the develop option. Nobody wants to specify an option while knowing it won't be used.

The warning is just to tell "you have specified 'develop=' but your develop-egg is not used and the egg version x.x is used instead.

Christophe


or have to change all their builds in order to accommodate
your thinking? We all know what the solution is, it was supplied at the beginning of the thread:

[versions]
mynewpin = somenewversion_dev

Aaron Lehmann


_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to