Shane Hathaway <[EMAIL PROTECTED]> writes:

> Philipp von Weitershausen wrote:
>> So overall I'm +1
> +1 from me as well on IFoo.adapt() with the signature Chris suggested. 
> "zope.component.getMultiAdapter()" is only easy to remember if you're a 
> die-hard Zope coder, while IFoo.adapt() seems more useful to the larger 
> Python community.

A similar suggestion was hammered out last September; I guess September
is the official month for the annual reconsideration of adaptation
syntax? :-)

I'm encouraged by the fact that this time it looks like people with time
are interested enough to actually begin producing code?  At the time
that I made the 2007 proposal I was still very new to the code base and
never got the courage up (or time available) to start making changes...

Brandon Craig Rhodes   [EMAIL PROTECTED]

Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to